Odhcpd insists on advertising local ULA interface address for DNS

Using odhcpd-full. dnsmasq not installed. Unbound installed but stopped and disabled. I have a Pi-hole server running on my LAN set to provide DHCPv4 and IPv6 support enabled (RA advert of its SLAAC address as a DNSv6 server, this is working)

However, odhcpd continues to RA its local ULA address (fd38:682c:8fab::1) as a DNSv6 server even when no DNS service is running on it, which causes LAN clients to hang since they are trying to query it.

Can someone please advise me on how can I stop odhcpd from advertising its local interface as a DNSv6 server?

/etc/config/dhcp


config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'disabled'
        option dhcpv6 'server'
        option ra 'server'
        option dns_service '0'
        option ra_dns '0'
#       list ra_flags 'managed-config'
        list ra_flags 'other-config'
#       list domain 'home.arpa'
        list dhcp_option '42,172.17.10.1'
        list dhcp_option '56,fd38:682c:8fab::1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

/etc/config/network


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd38:682c:8fab::/48'

config interface 'lan'
        option device 'eth0'
        option proto 'static'
        option ipaddr '172.17.10.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth2'
        option proto 'dhcpv6'

/etc/resolv.conf


# Interface wan
nameserver 192.168.1.254
search attlocal.net
# Interface wan6
nameserver 2600:1700:14b8:180::1
search attlocal.net

snip from win10 pc ifconfig /all

   Default Gateway . . . . . . . . . : fe80::92e2:baff:fe08:425c%9
                                       172.17.10.1
   DHCP Server . . . . . . . . . . . : 172.17.10.10
   DHCPv6 IAID . . . . . . . . . . . : 134275148
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-29-F4-AB-36-4C-CC-6A-7F-4A-57
   DNS Servers . . . . . . . . . . . : fd38:682c:8fab::1
                                       172.17.10.10
                                       2600:1700:14b8:18f:xxxx:xxxx:fedd:3315
C:\Users\matt>nslookup
DNS request timed out.
    timeout was 2 seconds.
Default Server:  UnKnown
Address:  fd38:682c:8fab::1

> test.com
Server:  UnKnown
Address:  fd38:682c:8fab::1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out

Let's shelve this for bit... a different win10 pc shows exactly what I expect for IPv6 DNS (pi-hole addresses only) and same with an Android phone and an iPhone.

Windows has DHCPv6....Android for example does not. The other DNS likely comes from SLAAC.