Odhcp6c problem with ipv6

Hello in logs i have multiple
Server returned message status 0
And my dual stack connection doesn't work...

To make it work i need to use 2 pppoe one for ipv4 and one for ipv6...

If i try to use 1 pppoe that supports both ipv4 and ipv6 my devices receive only a ipv6 address...

I think this is a openwrt problem as my legacy modem (openwrt based) that supports ipv6 handle it properly.

Try to extract its network config with Telnet/SSH/HTTP and compare with the current one.

See also:

I think my config is good. My ISP have some strange configuration with ipv6 so I think we should trace it down and adds some fix to odhcpd so I'm here to ask how to trace it down


Anyway may network config


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd49:5134:465f::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.2.1'
	option ip6assign '64'
	option ifname 'lan1 lan2 lan3 lan4 tap_softether'

config interface 'guest'
	option proto 'static'
	option netmask '255.255.255.0'
	option _orig_ifname 'wlan1-1'
	option _orig_bridge 'false'
	option type 'bridge'
	option metric '10'
	option ipaddr '192.168.20.1'
	option ip6gw 'fd49:5134:465f::2'
	option ip6ifaceid 'random'

config interface 'wan'
	option proto 'pppoe'
	option password 'testoh'
	option ipv6 'auto'
	option metric '0'
	option username 'ciaoca'
	option keepalive '0'
	option ifname 'wan'

config interface 'wan_ipv6'
	option proto 'pppoe'
	option ipv6 'auto'
	option keepalive '0'
	option username 'adsl@alice6.it'
	option password 'adsl@alice6.it'
	option ifname 'wan'
	option metric '10'

config interface 'modem'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.7'
	option ifname 'wan'


my dhcp config


config dnsmasq 'global'
	option expandhosts '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option domain 'Ansuel-Network'
	option cachesize '2000'
	option local '/Ansuel-Network/'
	option rebind_protection '0'
	option sequential_ip '1'
	option localise_queries '1'
	option boguspriv '0'
	option noresolv '1'
	option port '53'

config dhcp 'lan'
	option interface 'lan'
	option start '2'
	option force '1'
	option limit '200'
	option dhcpv4 'server'
	option master '1'
	option leasetime '24h'
	option ra_management '1'
	option ra 'server'
	option dhcpv6 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config host
	option name 'Ansuel-Gaming'
	option mac '10:c3:7b:92:19:ff'
	option ip '192.168.2.5'

config dhcp 'guest'
	option interface 'guest'
	option limit '200'
	option leasetime '1h'
	option start '2'
	option dhcpv4 'server'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'

config dhcp 'tor'
	option interface 'tor'
	option start '2'
	option stop '100'
	option leasetime '12h'
	option limit '150'

config host
	option mac 'e8:de:27:c9:68:82'
	option name 'Ripe-Atlas'
	option ip '192.168.2.3'

config odhcpd 'odhcpd'
	option maindhcp '1'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '3'

config host
	option name 'Samknows-Whitebox'
	option mac 'd8:37:be:fd:f3:6d'
	option ip '192.168.2.6'

Take notice that i don't use dnsmasq.... I use odhcpd for dhcpv4 and dhcpv6

Any help? Pls

I would be happy to help but my IPv6 is not native and the connection is IPoE.
Let's hope there's someone more experienced.

Ah, I see you also have TIM and a Whitebox too, small world this is :slight_smile:

I had manager to get IPV6 "sort of working" but it was terribly unreliable and I just gave up: in the end, I used the he.net tunnel for both the lan and the guest networks.

Yep... Ipv6 from Tim is sh*t but problem here is not performance but connectivity with mobile device..
Did you have the same problem?

Nope, packet loss was through the roof and it was unusable.
In the linked post you can find sections of my config, you're welcome to try with those.