Odhcp6c is flooding logs with "Failed to send SOLICIT message to ff02::1:2 (Network unreachable)"

This is driving me nuts, odhcp6c keeps flooding log messages every few minutes with daemon.err odhcp6c[3675]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
I tried everything I found on the internet and on this forum, but it didn't stop.
My ISP doesn't support IPv6, so I don't need it.
How can I get rid off these log messages?

Sun May  5 22:04:44 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:06:52 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:08:50 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:11:03 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:12:56 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:15:04 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:17:01 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:19:15 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:21:17 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:23:20 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:25:33 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:27:41 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:29:55 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:31:57 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:33:55 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:35:58 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:38:06 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:40:04 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:42:02 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:44:10 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:46:18 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:48:26 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:50:18 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:52:16 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:54:24 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:56:32 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 22:58:45 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:00:43 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:02:36 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:04:44 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:06:46 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:08:44 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:10:37 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:12:29 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun May  5 23:14:22 2024 daemon.err odhcp6c[6575]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
root@modem:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'
        option ds_snr_offset '-40'
        option line_mode 'vdsl'
        option firmware '/lib/firmware/vr9-B-dsl.bin'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'lan1'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config device
        option name 'lan2'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config device
        option name 'lan3'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config device
        option name 'lan4'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config device
        option name 'dsl0'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan'
        option device 'dsl0.35'
        option proto 'pppoe'
        option ipv6 '0'
        option username 'removed'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '8.8.8.8'
        option password 'removed'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

config device
        option name 'pppoe-wan'
        option ipv6 '0'

config device
        option name 'wan'
        option ipv6 '0'
root@modem:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option noresolv '1'
        option localuse '1'
        option confdir '/tmp/dnsmasq.d'
        list server '1.1.1.1'
        list server '8.8.8.8'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'guest'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'guest'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
root@modem:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include 'pbr'
        option fw4_compatible '1'
        option type 'script'
        option path '/usr/share/pbr/pbr.firewall.include'

Edit wan6, in general settings mark - disable this interface

1 Like

There's no such a setting in there. But unticking Bring up on boot did the job :+1:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.