Odhcp6c and ipv6

Hi
I have wifi repeater with ipv6 connected running 18.06.1 to upstream wrt router.

config globals 'globals'
        option ula_prefix 'fdea:0bd2:ad40::/48'

config interface 'wifi9'
        option ifname 'wlan9'
        option proto 'dhcp'

config interface 'wifi99'
        option ifname 'wlan9'
        option proto 'dhcpv6'

On startup everything is fine. I have ipv6 addressing and both ipv4/ipv6 dhcp are running

wlan9     Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          inet addr:192.168.7.200  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fdd1:1bd8:da7a:20::af6/128 Scope:Global
          inet6 addr: fdd1:1bd8:da7a:20:12fe:edff:fef6:23f2/64 Scope:Global
          inet6 addr: fe80::12fe:edff:fef6:23f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:193561 errors:0 dropped:0 overruns:0 frame:0
          TX packets:161948 errors:0 dropped:0 overruns:0 carrier:0

 2756 root      1028 S    odhcp6c -s /lib/netifd/dhcpv6.script -P0 -t120 wlan9
 2757 root      1200 S    udhcpc -p /var/run/udhcpc-wlan9.pid -s /lib/netifd/dhcp.script -f -t 0 -i wlan9 -x hostname:

When I run

wifi down; wifi up

I lost the ipv6 addressing

wlan9     Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          inet addr:192.168.7.200  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fe80::12fe:edff:fef6:23f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:154 errors:0 dropped:0 overruns:0 frame:0
          TX packets:173 errors:0 dropped:0 overruns:0 carrier:0

Only this process is running

14233 root 1200 S udhcpc -p /var/run/udhcpc-wlan9.pid -s /lib/netifd/dhcp.script -f -t 0 -i wlan9 -x hostname:r

These are the messages in logread

Mon Sep 10 08:38:17 2018 daemon.notice netifd: Interface 'wifi99' has link connectivity loss
Mon Sep 10 08:38:17 2018 daemon.notice netifd: wifi99 (2756): Command failed: Permission denied
Mon Sep 10 08:38:27 2018 daemon.notice netifd: Interface 'wifi99' is disabled

what could be the problem?

I have seen that defined as '@wlan9'

@mbo20, Its definately option ifname 'wlan9'

Below is the result with @wlan9

config interface 'wifi9'
        option ifname 'wlan9'
        option proto 'dhcp'

config interface 'wifi99'
        option ifname '@wlan9'
        option proto 'dhcpv6'


wlan9     Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          inet addr:192.168.7.200  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fe80::12fe:edff:fef6:23f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2700 errors:0 dropped:0 overruns:0 frame:0
1 Like

So i have done abit of debugging

/etc/config/network

config interface 'wifi9'
        option ifname 'wlan9'
        option proto 'dhcp'

config interface 'wifi99'
        option ifname 'wlan9'
        option proto 'dhcpv6'

/etc/config/wireless  

config wifi-iface
	option device   radio0
	option network  wifi9
	option mode     sta
	option ifname   wlan9

When the wifi is shutdown

Tue Sep 11 23:17:39 2018 daemon.notice netifd: Interface 'wifi9' has link connectivity loss
Tue Sep 11 23:17:39 2018 daemon.notice netifd: Interface 'wifi99' has link connectivity loss
Tue Sep 11 23:17:39 2018 daemon.notice netifd: wifi9 (25171): udhcpc: received SIGTERM
**Tue Sep 11 23:17:49 2018 daemon.notice netifd: Interface 'wifi99' is disabled**

wifi99 is disabled by netifd and the network is not associate with the interface
When wifi is brought back up, only wifi9 is bought back up

Tue Sep 11 23:20:04 2018 daemon.notice netifd: Interface 'wifi9' has link connectivity
Tue Sep 11 23:20:04 2018 daemon.notice netifd: Interface 'wifi9' is setting up now
Tue Sep 11 23:20:04 2018 daemon.notice netifd: wifi9 (27216): udhcpc: started, v1.28.3
Tue Sep 11 23:20:05 2018 daemon.notice netifd: wifi9 (27216): udhcpc: sending discover
Tue Sep 11 23:20:06 2018 daemon.notice netifd: wifi9 (27216): udhcpc: sending select for 192.168.0.19
Tue Sep 11 23:20:06 2018 daemon.notice netifd: wifi9 (27216): udhcpc: lease of 192.168.0.19 obtained, lease time 86400
Tue Sep 11 23:20:07 2018 daemon.notice netifd: Interface 'wifi9' is now up
Tue Sep 11 23:20:09 2018 user.notice firewall: Reloading firewall due to ifup of wifi9 (wlan9)

If I modifed my /etc/config/wireless

config wifi-iface
        option device   radio0
        **list network  wifi9  **
**        list network  wifi99**
        option mode     sta  
        option ifname   wlan9

and bring wifi up, wifi99 is also brought back up

Tue Sep 11 23:24:37 2018 daemon.notice netifd: Interface 'wifi9' is disabled
Tue Sep 11 23:24:58 2018 daemon.notice netifd: Interface 'wifi9' is enabled
Tue Sep 11 23:24:58 2018 daemon.notice netifd: Interface 'wifi99' is enabled
Tue Sep 11 23:24:59 2018 daemon.notice netifd: Interface 'wifi9' has link connectivity
Tue Sep 11 23:24:59 2018 daemon.notice netifd: Interface 'wifi9' is setting up now
Tue Sep 11 23:24:59 2018 daemon.notice netifd: Interface 'wifi99' has link connectivity
Tue Sep 11 23:24:59 2018 daemon.notice netifd: Interface 'wifi99' is setting up now
Tue Sep 11 23:25:00 2018 daemon.notice netifd: wifi9 (29128): udhcpc: started, v1.28.3
Tue Sep 11 23:25:01 2018 daemon.notice netifd: wifi9 (29128): udhcpc: sending discover
Tue Sep 11 23:25:02 2018 daemon.notice netifd: wifi9 (29128): udhcpc: sending select for 192.168.0.19
Tue Sep 11 23:25:02 2018 daemon.notice netifd: wifi9 (29128): udhcpc: lease of 192.168.0.19 obtained, lease time 86400
Tue Sep 11 23:25:03 2018 daemon.notice netifd: Interface 'wifi9' is now up

Can anyone explain this?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.