Odd issue with printer after switch to new WAP hardware

Hello friends! I've got a weird issue I have been struggling to correct for several days now. Curious if anyone has some troubleshooting recommendations for me.

I recently switched from using 3x RT3200 boxes, used strictly as WAPs, to 2x GL-MT6000 boxes, also strictly for WAP use.

I have a Brother brand wireless laser printer that is several years old. It connects to my IoT VLAN + SSID over 2.4Ghz only. That SSID is WPA2 PSK and no other significant bells and whistles other than having 802.11k/r/v enabled. It has been working perfectly with the RT3200 unit which it was located closest to for ~2 years.

Fast forward to now, this same printer is associating with the same SSID/VLAN on the nearest MT6000 WAP. I can see it connected, no connection issues in the WAP log. The printer reports successful association to the AP. I can ping the printer from my other VLANs, no issue. My Apple devices, and 1 Windows box, can see the printer via their respective discovery protocols.

Problem Statement:
When I attempt to print to this printer, if I am associated to the same physical AP (same physical MT-6000, in other words), even if the client device is associated to another SSID/VLAN on another radio (read: separate MAC) on the same AP, the printer will state "Receiving Data" for some amount of seconds before then stating "Cancel Printing", thus ending the print job and never actually printing.

If I take the same client device and associate it to the other MT6000, I am able to print to this printer successfully. So in other words, if the printer STA and the client STA are on two physically separate APs, the print succeeds.

Also, I am able to print to this wireless printer from clients that are ethernet connected without issue.

Can anyone think of what would prohibit this from functioning when the printer STA and client STA are connected to the same AP, even if different radios within the same AP? I hope someone has some clues because I'm out of ideas. :wink:

Link to my configs:

Thanks!

I hate printers as much as the next person :grimacing: But, I'm bumping this once in hopes that someone might have a suggestion. Thanks!

Let's see the configurations of your devices (if you have multiple, please make it clear what each device is -- a system topology diagram could also be helpful if it's not entirely straightforward):

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Isolate clients enabled would do this....

1 Like

From my experience with the GL-MT6000 I would say.

  • Fix the 2.4GHz channel to 1ch.
  • Set disassoc_low_ack '0'.

Now printing is stable.

Check if the 'isolate clients' is not enabled in the Wireless > Interface Configuration > Advanced section

Affirmative, for testing I explicitly set option isolate '0' in my wireless config for each SSID. While '0' is the default, I wanted to ensure it was ruled out and set it explicitly to '0' several weeks ago.

I'm still experiencing this issue. I'm at the point of doing tcpdumps now to see if I can get a feel for where the communication breakdown occurs.

Thanks for your feedback! As another troubleshooting step, I actually have taken this particular printer completely off of WiFi and have it connected to the WAP via ethernet now. Wireless STA --> this printer via ethernet still fails if the STA is associated with the same AP to which the printer is physically connected.

Here are some configs. FWIW, I was running option multicast_to_unicast '0' as a temporary measure for testing this issue this morning. It's not my daily driver setting:

Wireless Config

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi'
	option band '2g'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'
	option log_level '1'
	option channel '6'
	option txpower '27'
	option noscan '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option band '5g'
	option country 'US'
	option cell_density '0'
	option he_bss_color '25'
	option htmode 'HE80'
	option log_level '1'
	option channel '40'
	option txpower '14'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key '<redacted>'
	option dtim_period '3'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option max_inactivity '15'
	option ssid '<redacted>'
	option mbo '1'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option pmk_r1_push '0'
	option ft_psk_generate_local '0'
	option isolate '0'
	option multicast_to_unicast '0'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key '<redacted>'
	option dtim_period '3'
	option ssid '<redacted>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option max_inactivity '15'
	option mbo '1'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option pmk_r1_push '0'
	option ft_psk_generate_local '0'
	option isolate '0'
	option multicast_to_unicast '0'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option network 'GUEST'
	option mode 'ap'
	option key '<redacted>'
	option dtim_period '3'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option max_inactivity '15'
	option ssid '<redacted>'
	option mbo '1'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option pmk_r1_push '0'
	option ft_psk_generate_local '0'
	option isolate '0'
	option multicast_to_unicast '0'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option network 'GUEST'
	option mode 'ap'
	option key '<redacted>'
	option dtim_period '3'
	option ssid '<redacted>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option max_inactivity '15'
	option mbo '1'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option pmk_r1_push '0'
	option ft_psk_generate_local '0'
	option isolate '0'
	option multicast_to_unicast '0'

config wifi-iface 'wifinet5'
	option device 'radio0'
	option mode 'ap'
	option ssid '<redacted>'
	option key '<redacted>'
	option dtim_period '3'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option network 'IOT'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'psk2+ccmp'
	option max_inactivity '15'
	option mbo '0'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option ieee80211w '0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option na_mcast_to_ucast '1'
	option pmk_r1_push '1'
	option isolate '0'
	option multicast_to_unicast '0'
Network Config
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	option igmp_snooping '1'
	option ipv6 '0'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.45.25'
	option gateway '192.168.45.5'
	list dns '192.168.45.5'
	list dns_search 'home.arpa'
	option delegate '0'
	option device 'br-lan.1'
	option force_link 'yes'

config interface 'GUEST'
	option proto 'static'
	option device 'br-lan.9'
	option ipaddr '192.168.9.25'
	option netmask '255.255.255.0'
	option force_link 'yes'

config interface 'IOT'
	option proto 'static'
	option device 'br-lan.99'
	option ipaddr '192.168.99.25'
	option netmask '255.255.255.0'
	option force_link 'yes'

config interface 'LAN6'
	option proto 'dhcpv6'
	option reqprefix 'no'
	option device 'br-lan.1'
	option reqaddress 'try'
	option delegate '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'eth1:u*'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config bridge-vlan
	option device 'br-lan'
	option vlan '9'
	list ports 'eth1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'
	list ports 'eth1:t'
	list ports 'lan4'
	list ports 'lan5'
Sys Parameters
# for f in $(find . -name hairpin_mode -o -name multicast_to_unicast -o -name isolate_mode); do echo $f; cat $f; done
./kernel/debug/ieee80211/phy1/netdev:phy1-ap1/multicast_to_unicast
0x0
./kernel/debug/ieee80211/phy1/netdev:phy1-ap0/multicast_to_unicast
0x0
./kernel/debug/ieee80211/phy0/netdev:phy0-ap2/multicast_to_unicast
0x0
./kernel/debug/ieee80211/phy0/netdev:phy0-ap1/multicast_to_unicast
0x0
./kernel/debug/ieee80211/phy0/netdev:phy0-ap0/multicast_to_unicast
0x0
./devices/platform/soc/18000000.wifi/net/phy0-ap0/brport/multicast_to_unicast
1
./devices/platform/soc/18000000.wifi/net/phy0-ap0/brport/hairpin_mode
1
./devices/platform/soc/18000000.wifi/net/phy1-ap0/brport/multicast_to_unicast
1
./devices/platform/soc/18000000.wifi/net/phy1-ap0/brport/hairpin_mode
1
./devices/platform/soc/18000000.wifi/net/phy0-ap1/brport/multicast_to_unicast
1
./devices/platform/soc/18000000.wifi/net/phy0-ap1/brport/hairpin_mode
1
./devices/platform/soc/18000000.wifi/net/phy1-ap1/brport/multicast_to_unicast
1
./devices/platform/soc/18000000.wifi/net/phy1-ap1/brport/hairpin_mode
1
./devices/platform/soc/18000000.wifi/net/phy0-ap2/brport/multicast_to_unicast
1
./devices/platform/soc/18000000.wifi/net/phy0-ap2/brport/hairpin_mode
1
./devices/platform/soc/15100000.ethernet/net/eth1/brport/multicast_to_unicast
0
./devices/platform/soc/15100000.ethernet/net/eth1/brport/hairpin_mode
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan4/brport/multicast_to_unicast
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan4/brport/hairpin_mode
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan2/brport/multicast_to_unicast
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan2/brport/hairpin_mode
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan5/brport/multicast_to_unicast
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan5/brport/hairpin_mode
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan3/brport/multicast_to_unicast
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan3/brport/hairpin_mode
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan1/brport/multicast_to_unicast
0
./devices/platform/soc/15100000.ethernet/mdio_bus/mdio-bus/mdio-bus:1f/net/lan1/brport/hairpin_mode
0

Additional Troubleshooting:

  • I have taken this particular printer completely off of WiFi and have it connected to the WAP via ethernet now. Wireless STA --> this printer via ethernet still fails if the STA is associated with the same AP to which the printer is physically connected.
  • As an extension of the test above, if I connect a client to the same WAP via ethernet and attempt to print to this printer, also now ethernet connected, across VLANs it still fails.
  • Having an ethernet connected client print to this ethernet connected printer, both wired to the same WAP, on the same VLAN works.

Am I looking at a bridge configuration issue? The firewall is disabled on the WAP, so that should not be in play here. I'm trying to reason through where to head next.


More...

IPP uses port 631. I've confirmed my printer is using IPP from my Apple devices. I'm able to confirm that port 631 is not blocked between my "LAN" subnet and IoT subnet (where my printer lives).

❯ telnet 192.168.99.105 631
Trying 192.168.99.105...
Connected to brotherprinter.home.arpa.
Escape character is '^]'.
^]
telnet> quit
Connection closed.