Not the full speed detected on Archer C7 v5


Last week i updated my OpenWrt to version (from 19.07.02 to 19.07.03) and my Fritzbox, before this updates I've got sometimes 1000Mbits.
I don't know which update brokes this constantly, I sended a mail to AVM, but the guy from there says this is a problem from OpenWrt's energiesaver, is there really something like a energiesaver in OpenWrt?
When i go to the WebUi on the tab switch i can see all of my ports and my WAN port is set to 100Mbits, can I change this to set force up to 1000Mbits?

Regards Lucki1000

One moment: you mentioned the Archer but then you talk about a Fritzbox, is that an editing error or do you really have two devices, one of which you upgraded? If so, how are they connected?

Next, I'm not sure you can actually set the network speed from the gui, for sure you can do that from the cmdline but normally it is just set to "auto" and the two endpoints negotiate the appropriate speed between themselves.

Yes I have a Fritzbox(Cable) and in my room i have a Archer C7 v5 (connected over lan) and both get's a update last week.

So, if I understand correctly:

  • Fritzbox with original firmware as main router
  • Archer with Openwrt as client of the Fritzbox
  • on the archer: openwrt upgraded from version ? to version ?
  • on the fritzbox: AVM pushed an upgrade

Can you try connecting directly to the "other" device, maybe with a laptop, over ethernet? That is, connect your client to the archer if you're now using the fritzbox and viceversa but leave them connected as they are right now with respect to each other.

Correct, i connected my PC with my archer here did luci show 1000Mbits and the same if i connect my laptop the the Fritzbox it shows also 1 Gbit/s, the only device who is wrong detected is my OpenWrt router.

Ok, could you now try a different cable between the Archer and the Fritzbox? Maybe move the Fritzbox next to the Archer if you don't have a "known good" cable that is long enough.
For example the cable you just used for the laptop is probably good since you get 1000mbit on both devices.

Sorry for the delay, i have bought a new cable but still same behavior, how can i force the 1000Mbits in cli?

AVM Fritzbox has a power save checkbox to limit ports to 100M in its UI.

In my CableBox there is no checkbox or something like a energiesaver.

Plug the WAN cable into any known good Gb device and confirm the router link comes up at 1000. This will tell you if the problem is the modem or the router.

That have I also done and there i get also 1000Mbit.
Sometimes it goes, like if i connect the wan cable to another port it was shown as 1000Mbit/s and if i reswitch to the wan port it work for some hours but then it goes down to 100Mbits.

You could reconfigure the switch to move the WAN VLAN to one of the other ports, in case there is a hardware problem with the stock WAN one (port 1 I think).

mii-tool or ethtool, but they're not installed by default because... it's a bad idea to override autodetection, I guess.

So you don't have this menu :man_shrugging:?

Yes, I really dont have this menu :slight_smile:

How to assing the wan interface of a lan port? Is there a tutorial?

Go to the Network:Switch page. Notice how the LAN ports are "Untagged" in VLAN 1 and "off" in VLAN 2, while the WAN port is the opposite. Choose an unused LAN port and set it Untagged in VLAN 2 and off in VLAN 1 like the WAN port. Turn the original WAN port off in both VLANs to isolate it in case it is bad. Plug the modem into the new WAN port.

Unfortunately I did not manage to do that, but I have solved my problem now by reflashing over tftp.

Thanks for all of your support :+1:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.