Not all devices can see the OpenWRT WLAN SSID

I'm new to OpenWRT. And I've started using it because I got myself an GL-iNet travel router which wasn't seeing networks that were broadcasting above channel 11. There were no settings to change it in the default GL-iNet firmware, which is net verry useful for a travel router...

So, I'm actually having the GL-AR300M16, and flashed it with OpenWRT today. I've flashed using an UTP to my laptop and to configure the basics so far. Apparently WIFI was off on default so I needed to turn it on over UTP.

The main reason getting over to OpenWRT is because the router couldn't find networks above channel 11 (I think because those GL-iNet routers are standard set to USA). Now with OpenWRT installed I was able to find my own router (channel 12) when changing the country to NL in wireless settings.

So far so good.

All the settings kept original so far, besides the host name, the SSID name, the wireless password and the Luci admin password. So nothing really special.
But I can see the wireless network SSID with my telephone and I'm able to connect and login to the admin page. Same goes for another phone.

But strangely enough I can't see the wireless network SSID from my laptop.

I've scrolled through the settings of Luci a bit. But I can't see any strange things so far.

So long story short:

  • Wireless radio is turned on
  • 2 smartphones can see the wireless network
  • But my (windows 11) laptop can't see the wireless network.

I'm actually thinking I'm missing something here in the settings. However didn't tried to connect wireless from my laptop to the router when the original firmware was installed, so can't tell if this was working back then.

Anyone has any idea about this?

If you're using channels above 11 in the 2.4G band, your laptop's wifi radio may actually be the limitation. It is entirely possible that the laptop's wifi hardware my not be capable/tuned/firmware-allowed for those channels.


Thanks for your response.

My "home router" is broadcasting at channel 12. And my laptop and all other devices I have see this network and are able to connect to it.

The GL-iNet router, which I would like to use as a travel router, could not see channels above channel 11. Seemed to be a regional setting.


  • All my devices can see and connect to standard home network (channel 12).
  • 2 tested devices (mobile phones) can see the newly broadcasted network from the travel router (channel 1).
  • my laptop can see the network of the home router (channel 12) but can't see the network of the travel router (channel 1). (the laptop also finds the neighbors network which is broadcasting on 12 or 13, so the laptop should not be the problem here regarding to the channels above channel 11).

So the problem with channel 12 was actually the GL-iNet firmware, which was restricting seeing networks all above channel 11. This problem is solved now by flashing OpenWRT.

So the problem is with your laptop unable to see the ssid with the channels lower than 12?

Let’s see your config.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/wireless

It seems my laptop is seeing all kind of different networks here in the street. It's a whole list and when I check a similar list with a network scan app on my phone, then it tells me that all those network vary from channel 1 to channel 13.

I was just counting the networks I'm seeing with my laptop (over 40, varying from all kind of channels) while typing this, and then I saw the "travel router" too for a while. I've made an extra channel to test with (1 on ch1 and the other on ch6).
And I saw them both for a short while. But they disappeared again now. Strange, because the router is near and both my phones say the signal is pretty strong.

Well it seems that both of the broadcasted networks schare the same channel, so when changing the channel in SSID-1, SSID-2 gets the same broadcasting channel. So both of them turned to channel 6,

But most importantly, when I change the broadcasting channel of the travel router, then both SSID's are temporarily visible between the list of networks my laptop sees. But just for maybe 1 to 3 min.

Are you saying both channels are configured at the same time?

Yea, I think it will clarify things if can we see your configuration.

How do I share my config? Extracting it from a saved/backed up config file?

That's one option, or as was suggested:

Do I execute this from a build in Command line?

I see "/etc/config/wireless" is listed in the backup file list?

You can...but...

It really doesn't matter which manner is used to display/access the file - we just need to see it in order to better assist you.

If you're already looking at it in the backup file list, just open the file, copy the contents and paste them it here in codeboxes </>. Remember to redact passwords.

Couldn't find the command line, is it somewhere in Luci?
So took it from the backup file for now:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option band '2g'
	option country 'NL'
	option cell_density '0'
	option htmode 'HT20'
	option channel '6'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'SSID-1'
	option encryption 'sae-mixed'
	option key '******'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'SSID-2'
	option encryption 'psk2'
	option key '******'

btw. it seems that my laptop so now and then sees one or both of the networks. I had created SSID-2 to test with diferent parameters.
But when then show up, it's just for a short while.

My laptop is positioned just 3m from the router, same room/distance as the mobiles. So distance or coverage should not be the problem.

That's the default contents of the file, notice how it's defined to operate on channel 6; we need to see the contents of your current configuration.

Maybe I'm misunderstanding you here. But that's my config. I put to use channel 6, it was standard set to ch1.
Actually tried a few different channels, to look if it mad any difference. Left everything besides that and SSID/encryption option to standard values.

Couldn't find this command line, so I've backed up my config in system and took this from the /config/wireless folder of the backup.

  • Is your laptop still connected to another AP while performing this scan/observation?
  • So to be clear, your other devices see the AP OK (i.e. it's just a laptop issue)?

For future reference: