Not able to downlaod packages from

Me neither. It has been happening since yesterday. Nsloopkup returns SERVFAIL. All domains are affected.
I am using OpenDNS and adding to the list of DNS servers fixes the issue.

Me neither, Which is ip i am able add to host in my pc.

The root Nameservers for the domain


are not returning proper answers to (www.)
As the servers are still broken this will propagate through all the caching DNS Servers throughout the day and everyone wont be able to access these sites until this gets fixed.

Edit: you could probably try forcing a host entry with this ip:
Edit2: I collected some info from some cached dns replies.

# not really needed

This should get everyone somewhat up and running.

Edit3: Sorry for the passive aggressiveness above, i got rid of it.
Just got a link from the irc with all ips:

FYI: There is a discussion on the mailing list ongoing regarding DNS servers for
Hopefully the changes will propagate quickly through the DNS servers and make accessible again.

As thomas indicated, an update to the DNS was put in over the weekend, but is taking time to propagate. A quick fix is to set your router to point at the OpenDNS servers at and
I did that this AM and am able to access the domains resources.

Just tried and it is not working yet for me.

That will not work for long, as once the "root" info about gets stale at opendns, that opendns server needs to get new validation from the root DNS server, which is now down.

@jow posted a temporary workaround in Global DNS outage

You can direct your own DNS client/server (your Openwrt router) to believe that has the correct DNS root info for the whole domain. Jow has configured that with the needed info about the domain.

I did that and all other services work now for me except that is apparently in the same physical server complex as the main DNS server.

1 Like

I already did that and it is working, thx.

OK...this is true...

  • what were the original A Records' TTL?
  • were the NS Records changed, if so what were their the original TTL?
  • if the NSs changed, do these reflect actual changes at the registrar???

Telling people to make A Records is not good practice...also, this is not how propagation works.

Lastly, from what I can see, (at the time of my post) there are no active NS Records for OPENWRT.ORG. at the ORG. Root. The new records should exist.

Did you read jow's message that I linked above
The whole thing is due to hardware failure during weekend that took down the name servers.

he means dns is more massed while somebody tried to change authritive nameserver that now DNS for won't work even if the machine failed came back online

1 Like

The domain info at the registrar has finally been updated a few hours ago (2018-05-08T03:03:51Z) with new name servers.

The correct new info (name servers set for

Domain Name: OPENWRT.ORG
Domain ID: D104186352-LROR
Registrar WHOIS Server:
Registrar URL:
Updated Date: 2018-05-08T03:03:51Z
Creation Date: 2004-04-02T22:32:12Z
Registrar Registration Expiration Date: 2019-04-02T22:32:12Z
Registrar: TUCOWS, INC.

Things should get fixed soon (except regarding that is on the same physical hosts as the old name servers at

You can find the Chaos Calmer stuff also at
leading to

(seems that has not yet recovered from the DNS outage)

Thank you very much hnyman.I am now able to download packages,

I did read. I've just never used a non-specified master - or seen one fail in-production. I get it now.

Glad it's in order.

Correct, that's what I was alluding to.

This was the correct fix.
At the time of my first post:

dsktp:~$ dig -t NS

; <<>> DiG 9.11.3-1ubuntu1-Ubuntu <<>> -t NS
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 51204
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;			IN	NS

;; Query time: 387 msec
;; WHEN: Mon May 07 21:40:22 EDT 2018
;; MSG SIZE  rcvd: 40


dsktp:~$ dig -t NS

; <<>> DiG 9.11.3-1ubuntu1-Ubuntu <<>> -t NS
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11876
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;			IN	NS

;; ANSWER SECTION:		1800	IN	NS		1800	IN	NS		1800	IN	NS

The problem reappeared. The server downtime is now 5 hours. The server disconnected just when I was updating the packages. Device did not start after the restart. I had to make a new flash. I'm sitting and waiting to reinstall the system, at least to some usable form for installing packages, and in the morning the device was ready to work.
OpenWrt has dropped to a very low level in my eyes.

It's a paradox. So many people are devoting time to developing an entire operating system to provide global alternatives and "better" options than official routers provide. And the thing like having packages and firmware available at all is at a level where you don't get to them at all for quite a long time. The question is whether the owner knows about the outage and it would not be appropriate to use a watchdog, because outages are quite common for many years.

is not accesible.

1 Like

yep, its down! confirmed

Workaround posted in another thread about this issue. Unable to access Gateway Time-out) (502 Bad Gateway)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.