Not able to access internet

Hello everyone,
I have got my omega2 pro board 2 days back.
I booted omega2 pro with OpenWrt(

I am able to access

I have enabled the wifi access point and provided the LAN connection to the ethernet port on the device.

I am facing a few problems.

  1. I am able to connect to the wifi from my laptop and access the internet but I am not able to connect to the wifi from my phone. also, I am not able to access when I connect to OpenWrt wifi

  2. When I connect through putty(as serial port ), I am not able to access the internet from the command line. opkg is failing.

  3. I want to achieve an 802.11s based wireless mesh network Where I connect LAN cable to the ethernet port, OpenWrt act as Accespoint so that other devices can connect to this access point and communicate to each other.

I am very much new to this field. Thanks in advance.

Before you set up mesh (which requires installing wpad-mesh-openssl and removing wpad), try to configure wifi network with WPA2-PSK or WPA/WPA2. Make sure all clients can connect.

First, try connecting with an Ethernet cable. Do you seen

After connecting the Ethernet cable I am not able to see but I can connect to the internet from my laptop.

I followed the command line instruction given on Now I am able to connect my android phone to the wifi.

Still no internet inside the putty.

putty is serial link, there is no Internet.

What happens when you type:
opk update


for ping its saying ping:bad address ''
and for opkg update it says

Failed to establish connection
*** Failed to download the package list from

Single ethernet port boards are usually run as a LAN device (dumb AP) where routing to the Internet is done by the network's existing main router. Configuration for this is:

  • ethernet port and optional wifi AP bridged into the existing by default lan network.
  • lan IP in the range of the main router but not the same. DHCP client is also acceptable but you will need a way to determine which IP was assigned.
  • lan options gateway and dns point to the main router.
  • DHCP server disabled in /etc/config/dhcp. In the lan section disable both IPv4 (add an option ignore) and IPV6 (comment out / remove IPv6 related lines)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.