Nordvpn on Linksys WRT32000acm with 18.06

I now have problem with making a VPN with Nordvpn
I'm trying to follow this guide, a guide with pictures it's easy for me.

I'm starting to make an interface that the guide describes but I can't "cover the following interface" for tun0

I can't make a new one just pick those who are there.

I also can't "Create / Assign firewall zone"

I am clear that it is a guide on an older version from LEDE

Can you post a screenshot?
If we give you the commands, will you be able to import them via SSH?

Yes i believe well i can find out to do it via ssh, i am reading a part about openwrt

Here you are:

uci set network.nordvpn="interface"
uci set network.nordvpn.ifname="tun0"
uci set network.nordvpn.proto="none"
uci commit network
service network restart

Continue the guide from the point that says Now click the "Advanced Settings" tab and select "Bring up on boot".

Maybe I couldn't figure it out.

Collected errors:
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:1: Ignoring invalid line: `uci set network.nordvpn="interface"'
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:2: Ignoring invalid line: `uci set network.nordvpn.ifname="tun0"'
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:3: Ignoring invalid line: `uci set network.nordvpn.proto="none"'
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:4: Ignoring invalid line: `uci commit network'
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:5: Ignoring invalid line: `service network restart'
 * opkg_conf_load: Could not lock /var/lock/opkg.lock: Resource temporarily unavailable.

A restart of computer and router, helped succeed

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


The problem is not completely resolved.
When I get to "WinSCP" in the guide, I do not have a folder on my router called openvpn or nordvpn where I can put the folder with NordVPN Profile out.
I've tried to make a folder myself, but then I can't make it work.
I have followed the guide completely

opkg list-installed openvpn\*
ls -l /etc/openvpn

I have now created the folder openvpn but I still can't get my vpn to work.
Then I would try to look in /tmp/openvpn.log

But when I open winscp, this error comes:

and i don't even have a folder called tmp, can something have gone wrong during instalation of openwrt?

I have these folders:

Yes, something is really wrong there as you are missing quite a lot of folders like tmp, usr, root, proc.
Are you sure you didn't erase anything accidentally?

Yes, because before I started with VPN, I checked that there was a connection to the router with winscp and with PuTTY and that winscp also reported errors so it is before vpn and all i have done before is make a wifi and switch ip from to

Should I make a new installation 18.06.02?

Definitely yes.
I would tell you to login with SSH and run firstboot to restore factory defaults, but I am not sure if login will work.

Okay, I'll try to make a firstboot.
I have been looking for a folder overview so I can check I have all the folders. Where can I find one?

bin           etc           mnt           proc          root          sys           usr           
dev           lib           rom           sbin          tmp           var

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.