Noobie ipv6 ISP questions

Hello everybody,

first, English is not my first language, so I apologize in advance for all the inevitable spelling mistakes.

A bit of background info. Networking is not my area of expertise, and I know just enough to be dangerous to myself and my networking equipment. I can comfortably use the LuCI interface and even SSH into my router if need be.

A long time ago I set up my router, input the ISP provided pppoe username and password, set up wifi, a pihole, forwarded a port for a local minecraft server and that's it. Every 3-6 months I check that I am up-to-date with the latest version, but that is it. The router functions in a "set it and forget it" manner for me.

Now I just received ipv6 connection information from my ISP and in an effort to set it up I have been looking at the wiki and googling around the net, but I am feeling a bit overwhelmed and confused, so I have turned to this community for help. And yes, I know that these will be extremely noobie questions.

As stated above I already have a pppoe connection to my ISP on ipv4 now I would like to set up the ipv6 connection/interface. How do I correctly set up an ipv6 connection to my ISP.

The ISP provided is the following in an SMS:
Framed-IP-Address = < ipv4 address >
Framed-IPv6-Prefix = < XXXX:XXXX:XXXX:X::/64 >
Delegated-IPv6-Prefix = < XXXX:XXXX:XXXX:XXX::/56 >

-Where do I input this info?

-Is the terminology in the LuCi interface slightly different from the provided info?

-Should I use the default DHCPv6 client or a static address on the WAN6 interface?

-Is configuring the WAN6 interface even the correct thing to do? Up to now, ipv6 addresses came through the WAN interface and the PPP link set to automatic.

In short, please help.

Thank you for your help and patience,
a noobie.

Hello there,
It is not crystal clear which protocol your provider is using. Judging by the description I'd say it looks like 6in4. In this case you'd have:

config interface 'wan6'
        option proto        '6in4'
        option peeraddr     'ipv4 address'
        option ip6addr      'XXXX:XXXX:XXXX:X::/64'
        option ip6prefix   'XXXX:XXXX:XXXX:XXX::/56'

You need to install the package 6in4 for that.
Better talk to your ISP first and verify my assumptions.

1 Like

A day and a half later I just got off the phone with the ISP.

They expect a pppoe connection using the existing username and password that I have for ipv4 and the provided Framed-IP-Address as a static address for the connection. And that I should create a separate interface from the already existing one servicing ipv4 addresses.

A big thank you to trendy, I had a big "head meet desk" moment when you mentioned that I should install the package 6in4. I was reading the IPv4/IPv6 Transition Technologies page on the wiki and asking myself why I was not seeing all of these options. Yeah, take a moment to appreciate the amount of "not thinking" needed to accomplish this.

Also, trendy as soon as you posted the reply I tried your suggestion with 6in4 both in LuCi and SSH-ing into the router just to be sure. Didn't work, kind of obvious now that the ISP returned my call but just wanted to say thank you again.

I just quickly wrote this when I got off the phone with the ISP. I now need to read up on how to setup a pppoe connection using the above provided data. Just browsing through the options in LuCi I haven't yet figured out what I need to do. If any of you can help point me in the right direction, much appreciated.

In continued thanks of your help and patience,
a noobie.

I still don't understand which protocol does your isp use to provide ipv6. Is it static ipv6? Is it DHCPv6 and router advertisements? Is it 6in4? Is it dslite? Is it some other protocol? Didn't they tell you over the phone? Don't they have any wiki or helpdesk webpage explaining the configuration details?

What I got over the phone is that I need to create a ppoe connection with my login credentials that I have for my pppoe ipv4 connection and then have the provided "Framed-IP-Address" which is a ipv4 address as a static ip.

When I asked what protocol they are using the engineer started talking about CHAP usernames and passwords and it took me half a minute to figure out he meant a pppoe connection. When I asked him if he meant pppoe he said yes and to make a pppoe connection with the static address provided to me in the SMS. From the conversation I had I got the sense that they expected me to input what they sent me into a pppoe connections options panel. When he asked me what router I was using I told him it was a TP-Link Archer C2600 with OpenWrt, his response "Ah OpenWrt, custom software". Which I get, I don’t expect them to troubleshoot my setup. But some clarity would be nice about what they expect from users/customers.

As for a web page, in addition to the standard telecom/mobile provider “buy this new phone and pay for the next 2 years” sales page they have a forum where 90% of threads end with, "This is a very specific case, please PM us your account info so we can help you get this resolved". In other words, useful it is not. They do have an ipv6 page, it is a news article about how they "enabled a new internet protocol" .... from 2012.

I do apologize if this is a bit of a rant and not helpful in the given situation but I needed to …discharge a bit of pent up frustration. I’ve been trying to setup this thing up for a week and asking for help online where the world can see is not easy for me as an introvert, new territory and all that.

Again, thank you for helping trendy. You are very much appreciated.

for alot of stuff that sort of makes sense... but wan connections are all 'custom' mixes of standards...

for my ISP OpenWrt is one of, if not the best OS in terms of ipv6 interoperability...

ISP's provide wan connections... they are obligated to provide technical details on how they have implemented the standards... ( unless they lock you into hardware via contract in which case it is usually them doing the 'custom stuff' )

So I did the dumbest thing I could think of and just re-enabled the obtain ipv6 address option (by turning it back on automatic) in my existing ipv4 connection to my ISP. The following happened…

The LAN interface gets another IPv6 address in addition to the one it already had. It is the first possible one in the Delegated-IPv6-Prefix range. It is a /60 format.

The WAN interface gets the Framed-IP-Address as the ipv4 address. This is the "static address" that I should be using to connect to get ipv6.

The ipv6 address is a /128 address that does not fall within the range of any of the ipv6 prefix addresses that the ISP sent me

The WAN6 interface is just chugging along doing I don’t know what. It does this consistently if it is in DHCPv6 client mode/protocol.


The Wan_6 interface started appearing and disappearing 2 weeks ago when I called the ISP to setup ipv6. Then a week ago it started going through a crash cycle with the pppoe connection. The ipv4 pppoe connection (WAN) went through a "disconnected by peer" / "negotiation failed" error followed by a crash and a restart. In response to this I disabled the obtain ipv6 option and the pppoe connection then stabilized.

Now the WAN_6 interface received an ipv6 address. It is in the range of the Framed-IPv6-Prefix they sent to me.

Both the Framed-IPv6-Prefix and the current WAN_6 ipv6 address are /64.

The WAN_6 IPv6-PD address is the Delegated-IPv6-Prefix the ISP sent me and /56.

I don't know what this tells me, but the fact that the ipv4 pppoe interface is not going through a loop of disconnections and crashes is an improvement. If I go to an ipv6 test website or try pinging Google I don’t have an ipv6 connection/address.

I have not touched my firewall settings, should I change something with the firewall?

So, it's the weekend and I decided to do everything again from scratch. I rebooted the router to the default configuration and setup my network again. Lo and behold ipv6 pinging Google works and the ipv6 test websites show that ipv6 is resolving correctly. I guess my ISP just needed a few days to do stuff.

The configuration as it stands now:
The WAN interface has a pppoe connection that has my ISP provided login information and the IPv6 negotiation on the PPP link option is set to automatic. The ISP then automatically assigns me the Framed-IP-Address they sent me as my ipv4 "static address". I also receive a /128 ipv6 address on that interface.

The WAN6 interface is the default one that I have not touched.

The WAN_6 interface is a Virtual dynamic interface (DHCPv6 client) that from my understanding is created by the WAN interface when it negotiates a ipv6 address via pppoe (do correct me if I am wrong on this). The WAN_6 interface receives a /64 ipv6 address that is in the range of the Framed-IPv6-Prefix that the ISP sent and an /56 IPv6-PD address that is the Delegated-IPv6-Prefix (all of this is also done automatically).

In the LAN interface options under the advanced settings I added the WAN_6 interface as the IPv6 prefix filter and in the DHCP server settings I turned the RA-Service, DHCPv6-Service and NDP-Proxy to hybrid mode. The IPv6 RA Settings are set to automatic. It now has only the one ipv6 address.

In conclusion everything works auto-magically. Which after a week of pulling my hair out is simultaneously great and not that satisfying, as I don’t really know what is going on.
I have read up a bit on what RA-Service, NDP-Proxy, … are but I am still feeling dangerously out of my depth. My questions basically boil down to what are the best practices with my setup that I should be following.

The ISP engineer I was talking to said that I should have a separate pppoe interface for my ipv4 and ipv6 addresses. Should I do this?

Do I just delete the WAN6 interface or should I adapt it so that the WAN_6 interface doesn’t need to be created in the first place?

Is everything ok with my LAN configuration, or did I mess something up?

They could just say that they assign an IPv6 on the pppoe and then use dhcpv6...
You can delete the wan6, as the automatically created wan_6 does all you need to have ipv6.

These are not necessary. Better roll them back. The setup you have is working out of the box in OpenWrt, as soon as you setup pppoe for the wan interface.

Ok, I deleted the WAN6 interface without any issues. I disabled the NDP-Proxy and removed the prefix requirement in the LAN interface (the second IPv6 ULA came back, which now that I know what the IPv6 ULA is, was another "aha moment" me).

If I disable the RA-Service or the DHCPv6-Service the ipv6 goes down so I set them up in server mode for both. Honesty I need to read up on what exactly all three of these things do before I can even ask any good questions. All of that is for next week along with setting up the pihole to work with ipv6.

Is there anything important that I should know of or that I missed or misunderstood?

If not then I think that this is it for now, I may return if I botch up anything in the future, but as far as setting up my ISP provided ipv6 connection that is hopefully it.

I guess that the old adage of "Turn it off and on again" rings true again.

A very big thank you to both trendy and wulfy23 for all the help and advice, just knowing that I was not staring into the abyss that is networking alone was a big morale boost.

In eternal thanks of your help and patience,
a noobie…. now with ipv6 :slight_smile:

Server is the default and will work in your case.

Ok, if everything else is fine then I think that that is it. I will mark this thread as solved.

Thanks for the help everybody.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.