Noob question about installing tmux

Hey I just started using openwrt again after a long hiatus on my new Linksys EA7500v2. Seems like it's only supported on snapshot for now but that's probably fine for my purposes.

I updated my packages with opkg update and then ran the following command to try to install tmux:

root@OpenWrt:~# opkg install tmux
Unknown package 'tmux'.
Collected errors:
 * opkg_install_cmd: Cannot install package tmux.

But when I tried googling it I found this hit on the package manager

which seems to indicate that it exists, so what am I missing here?

1 Like

Looking around more it seems like that package is maybe broken in snapshot which is why I can't download it.

Found this fail log: https://downloads.openwrt.org/snapshots/faillogs/mips_24kc/packages/tmux/compile.txt

Showing an error during the build:

checking for event.h... no
configure: error: "libevent not found"
Makefile:45: recipe for target '/builder/shared-workdir/build/sdk/build_dir/target-mips_24kc_musl/tmux-3.1c/.configured_68b329da9893e34099c7d8ad5cb9c940' failed
make[3]: *** [/builder/shared-workdir/build/sdk/build_dir/target-mips_24kc_musl/tmux-3.1c/.configured_68b329da9893e34099c7d8ad5cb9c940] Error 1
time: package/feeds/packages/tmux/compile#5.70#2.07#11.46
1 Like

@scurvybob, welcome to the community!

Did you run opkg update first?

1 Like

The buildbot has failed to build the package.
It's more or less normal for snapshots.
The OP can try again later, or try to build it himself.

4 Likes

Thanks @lleachii. I said in the OP that I ran opkg update.

Looking today that build failure I noticed before is gone.

One more opkg update and tmux installed.

Thanks everyone!

2 Likes

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.