Noob here please help setting up PPPoE and share internet with AP

Hi I'm trying to setting up LEDE with my Raspberry Pi2. I managed to install LEDE but stuck with network setup so my network plan is

Internet <---> ADSL Modem <--(PPPoE)-->(eth1)LEDE(eth0) <----> AP <----> Clients

my modem set to bridge mode with address

first I setup PPPoE

config interface 'wan'
	option proto 'pppoe'
	option ifname 'eth1'
	option username 'username'
	option password 'password'
	option service 'ADSL'
	option ipv6 'auto'

and my lan something like this

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask ''
	option ip6assign '60'
	option ipaddr ''
	option gateway ''
	option dns ''
	option _orig_ifname 'eth0'
	option _orig_bridge 'true'
	option ifname 'eth0 eth1'

my lan section also providing dhcp server

I think I'm messed up with lan section because when I use my pc connect into eth0(lan) I got address no internet access can't ping

can anybody guide me what I have to do to get it works thnak in advance and sorry for my English.

If your ADSL Modem has a address, it is probably also acting as a router, and doing all the PPPoE negotiation for you. Do you have internet connection on the router? Does it work if you configure the WAN interface as a DHCP client? Can you connect a computer to the modem and it just works?

I see you have bridged together the eth0 and eth1 interfaces, and that is incompatible with the WAN port having a public IP address.

Thank you eduperez
my modem acts as bridge mode it doesn't work if i configure the WAN as DHCP client

And yes I'm confusing now. with my understand i have to...
configure WAN interface (eth1)
configure LAN interface (eth0) but do not bridge with eth1
configure LAN interface as DHCP Server for my AP
am i right?

and how would traffic from WAN route to LAN?

First of all, configure your WAN interface on eth1, and make sure that it connects to the internet and acquires a public IP address. Then configure the LAN interface on eth0 alone, as a DHCP server, and check that devices can get an IP address from it.

You do not bridge two network interfaces together, unless you want to have the same network on both sides; and you do not want to do that, as you have a public network on the WAN side and a private network on the LAN side. You have to route and masquerade the traffic from the LAN to the WAN, and that is configured in the "firewall" file:

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option conntrack '1'
	option mtu_fix '1'
	option network 'wan wan6'

config forwarding
	option dest 'wan'
	option src 'lan'

Thank you very much esuperez now my network work like charm!