Noob help with mikrotik wap ac lte connecting using a sim

Hi all,

I have a mikrotik wap ac lte router: https://mikrotik.com/product/wap_ac_lte_kit

I installed openwrt on it and everything seems fine.

I have a data sim I want to connect to the web with. This sim connects to the web without problem on my phone.

I inserted the sim into the router's sim slot, and followed a tutorial I cannot now find. It involved installing a few packages necessary to use qmi, and modemmanager.

The sim card has no problem connecting my phone to the internet. My mobile provider says they are only responsible for ensuring this happens. I had to re-enter a few of the settings openwrt asks for, but not all.

My mobile internet provider gave me the following information. It does not over every field in the general settings page. :

  1. apn - They gave me the apn, and said the apn type was 'default'. I don't see any field into which I might enter the apn type in openwrt.
  2. pin - they didn't give me a pin.
  3. They didn't know what authentication type I needed. I tried pap, chap, none, and both at various times without being able to connect.
  4. username and password. They gave me a username and password.

I took the following steps but got a failed to connect error message.

  1. I go to Network > Interfaces > Add new interface.
  2. Select ModemManager for the protocol and name the interface sim.
  3. MikrotTik - R11e-LTE is pre-selected in the Modem device field.
  4. I tried the various authentication types, as mentioned above.
  5. I tried both ipv4 and ipv6 (and both, defaulting to ipv4).
  6. I left the 'signal refresh rate' field blank.

In the Firewall settings I chose WAN[WWAN]

Then I click 'Save and apply', then Restart, and I get:

Error: Connection attempt failed

Any help with this would be very much appreciated, thanks!

(I have been told by the person I bought the router from that I don't need an external antenna, but I am not entirely confident in their knowledge of the router. The mobile phone signal is fine at the location where I am trying to connect the router. If you know that it is simply the case that I need an antenna please let me know. I dont want to buy an antenna if I dont need one, or on the off chance that I might.)

Uninstall ModemManager and follow https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_ncm

Hi

Edit:

Thanks.

I will edit this once I have worked through any issues I may or may not run into/fix.

THanks!

You don't need *huawei* packages, so you can proceed without them.
Make sure opkg update completed without errors.

Hi,

Thanks again. I actually just managed to install it then edit my other reply.

I will get back to you after I have worked through/figured out any problems.

All the best!

Hi

So I am here:

root@OpenWrt:~# opkg install kmod-usb-net-huawei-cdc-ncm comgt-ncm luci-proto-nc
m
Package kmod-usb-net-huawei-cdc-ncm (5.15.137-1) installed in root is up to date.
Package comgt-ncm (0.32-35) installed in root is up to date.
Package luci-proto-ncm (git-22.209.60806-049d876) installed in root is up to date.

But I run/get the following:

root@OpenWrt:~# ls -l /dev/cdc-wdm0
ls: /dev/cdc-wdm0: No such file or directory
root@OpenWrt:~# ls -l /dev/ttyUSB*
ls: /dev/ttyUSB*: No such file or directory

On the following page: https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_rndis the tutorial you linked is described as "How to use LTE modem in NCM mode for WAN connection", which seems to fit my circumstance, however the page itself says " Use NCM USB Dongle for WAN connection", and I am not actually using a usb dongle. It is the internal lte modem on the router.

When I try and set up the interface using luci the "MikrotTik - R11e-LTE" does not appear pre-selected in the Modem device field.

Can I use the NCM protocol to access the above internal modem, or is it just for usb dongles?

If I can how do I access the internal modem rather than a usb device?

Thanks

Show the output of cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 5.15
S:  Manufacturer=Linux 5.15.137 xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=xhci-hcd.0.auto
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=2cd2 ProdID=0001 Rev= 1.00
S:  Manufacturer=MikroTik
S:  Product=R11e-LTE
S:  SerialNumber=000000000000
C:* #Ifs= 7 Cfg#= 1 Atr=c0 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=e0(wlcon) Sub=01 Prot=03
A:  FirstIf#= 2 IfCount= 2 Cls=02(comm.) Sub=02 Prot=01
A:  FirstIf#= 4 IfCount= 2 Cls=02(comm.) Sub=02 Prot=01
I:* If#= 0 Alt= 0 #EPs= 1 Cls=e0(wlcon) Sub=01 Prot=03 Driver=rndis_host
E:  Ad=8c(I) Atr=03(Int.) MxPS=  16 Ivl=4096ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=rndis_host
E:  Ad=8e(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=0d(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=01 Driver=cdc_acm
E:  Ad=84(I) Atr=03(Int.) MxPS=  16 Ivl=4096ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 4 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=01 Driver=cdc_acm
E:  Ad=81(I) Atr=03(Int.) MxPS=  16 Ivl=4096ms
I:* If#= 5 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 6 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=8b(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=0a(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev= 5.15
S:  Manufacturer=Linux 5.15.137 xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=xhci-hcd.0.auto
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms
root@OpenWrt:~# 

And thank you.

I assume this isn't a big deal, but I just tried install the packages required for either an NBIM or a QMI mode LTE modem. Installed the necessary packages

opkg install kmod-usb-net-qmi-wwan uqmi luci-proto-qmi kmod-usb-serial-option picocom

opkg install kmod-usb-net-cdc-mbim umbim luci-proto-mbim kmod-usb-serial-option picocom

Rebooted and again ran the same ls -l /dev/cdc-wdm0 command to again get 'device not found'.

You will need using /dev/ttyACMx instead of /dev/ttyUSBx, you can put /dev/ttyACM0 into configuration and see what is in the system log.
You don't need to install anything until advised to do so.

HI,

So I have followed the tutorial, editing /etc/config/network and /etc/config/firewall

I couldn't ping 8.8.8.8 so I looked at the device using luci.

When I choose Network Mode default, and device as /dev/ttyACM0 I get Error: Failed to get modem information

When I choose /dev/ttyACM1I get 'failed to configure modem' error.

Failed to configure seemed better than 'failed to get modem information' so I went with /dev/ttyACM1.

Trying different Network modes: LTE, Prefer LTE, Prefer UMTS, UMTS/GPRS, GPRS only, AUTO I get the same 'failed to configure modem' error.

Thanks

The only thing you need to do is show a fragment of your system log. Use </> button to properly format it. Remove all your customizations, run logread -f then restart the modem interface from the GUI. Post the log data collected.

This means that the connection script was unable to process some commands related to "configure" step.
If there is no obvious answer in the log, then in order to troubleshoot this I suggest to delete the NCM interface created earlier and manually run the following commands from a terminal like picocom so we can see what exactly the modem is not happy with.

AT+CFUN=4
AT+ZGDCONT=1,"IP","internet",0
AT+ZDHCPLEASE=10
AT+CFUN=1

Replace internet with your APN.

Hi
I have an AT-command script for the R11e-LTE, https://github.com/mrhaav/openwrt/tree/master/atc/mik-r11e_lte
and a LuCI app, https://github.com/mrhaav/openwrt/tree/master/atc

You need to install comgt first. My AT-command script use it.

I have no support for the LEDs, yet.

Hi MrHaav!

Thanks so much your script/LuCI app worked.

I really appreciate all of your efforts here.

Cheers and have a good day!

Hi Andrew,

Thanks for all of your efforts here - it is much appreciated. As it happens MrHaav's sript/LuCI app worked so no problem any more.

All the best.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.