Noob alert: can't connect to router after changing subnet

Hi everyone! Network newbie here. I managed to install OpenWrt 19 on my Archer C7 v2. I successfully connected to LuCI on I am trying to set up the router as a wireless repeater, and hopefully also as a printer and torrent/ed2k server.

As a first step I tried follow this tutorial, but failed miserably after the first step. I believe I have changed the router's IP to (I also tried this other tutorial), but I am then unable to connect again to the router.

My setup is as follows: I use a laptop with Manjaro 21 (Gnome 40) - Linux 5.10. I normally connect to the internet over Wifi (using a different router, provided by the local cable company). I am trying to configure the Archer C7 using an USB Ethernet adapter. After changing the Archer's IP I disconnected my Wifi adapter, changed the Ethernet adapter's IPv4 config (in Gnome's network settings) to Manual IP (, netmask to and gateway to I can't access LuCI nor ping the Archer. Only way to revive it now is to reset it to factory (i.e. default OpenWrt) settings.

I guess I must be missing some very basic step here, but I can't figure it out on my own.

Thanks for your help!