Non-bridged eth0 on Raspberry Pi 3B+ fails to work

I'm having problems configuring eth0 as a 'normal' NIC on a RPi 3B+ using the latest OpenWRT snapshot build. The default type is bridge of eth0 and wireless. I wish to disable this (comment out lan's 'option type bridge'), but then device will either reboot resetting changes or ping to the wired network will fail after network reload.
Any idea what I'm doing wrong?

I'm not sure how you're doing it. Try it in LuCI, it's very simple:

  • Uncheck the box beside the bridge option
  • Make sure eth0 is selected
  • Hit Save and Apply
  • Done!

Unfortunately, it's not that easy.
When I uncheck bridge option in LuCI (or comment/remove the option from the configuration file), I can no longer ping the wired network.

# dmesg
br-lan: port 1(eth0) entered disabled state
device eth0 left promiscuous mode
br-lan: port 1(eth0) entered disabled state
IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

link is not ready, but it's reported as UP:

# ip addr show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000

and ping has a 100% packet loss.

Sometimes re-adding bridge restores ping, sometimes restoring from backup helps.

This printout appears that you didn't apply the settings, as eth0 does not have an IP address.

  • Did you also ensure that the Radio Box still selects eth0???
  • Can you provide a screenshot of your LAN Interface's Advanced Page before hitting the Save button?

Ellipsis was there to show that there was more output that was omitted for brevity. eth0 did in fact get an ip.


I assume Radio Box is Interface in the screenshot above. Is that correct?

OK, you have a snapshot installed. Verify that only the eth0 box is checked on that list of Physical Interfaces.

and that your wireless config does not attach anything to LAN.

1 Like

Snapshot, true.
Is there any other list where only eth0 should be checked?

It doesn't work in either case. Neither when nothing is attached to wireless nor when I try to attach it to another network (which also doesn't seem to work).