No wireless associated and 5g radio off problem Xiaomi 4a gigabit edition router

Hi everyone i am recently flashed my xiaomi 4a gigabit edition to open wrt latest version but whenever i specify any 5ghz band it says wireless not associated and 5ghz radio gets disabled i tried restarting several times doesnt work...It only works if i set The 5ghz band to Auto...any help or fix will be appreciated...

Maybe you have tried channels which are not allowed?
Set the Country Code correctly and leave the selection on automatic.

can you tell me how to set the country code in openwrt??

In LuCI, navigate to Network > Wireless

Click Edit for the 5 Ghz device

Click the Advanced Settings tab

Country Code is at the top

I would not allow the router to automatically select the channel.

I have seen some select a DFS channel, which is reserved for radar.

Depending on your location, select in the range 36 to 48, or 149 to 161.

If you are still having issues with wireless after completing your configuration, SSH in to the router and run the following command...

cat /etc/config/wireless

Redact the passwords in the "option key" sections.

Post the output in pre-formatted text using the icon highlighted in red...

OpenWRT Posting Icons

yes i have changed country code to singapore but my country is actually Bangladesh and yeah its working now both bands are working....

but the 5ghz wifi ssid is not being showed on my mobile but it shows on my pc any fix for this?

i also would like to ppoe login on my router i only have its username and pass ...

i am also sending the output on the next reply

You may need to add it to your mobile.

You can change to PPPoE in Network > Interfaces > WAN > Edit > Protocol

BusyBox v1.33.1 (2021-10-24 09:01:35
 UTC) built-in shell (ash)
root@OpenWrt:~# cat /etc/config/wireless                                                  
config wifi-device 'radio0'                          option type 'mac80211'                       option hwmode '11g'                          option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'                          option htmode 'HT40'                         option txpower '20'                          option cell_density '0'                      option legacy_rates '1'                      option channel 'auto'                                                             config wifi-iface 'default_radio0'                   option device 'radio0'                       option mode 'ap'                             option encryption 'psk-mixed'                option key 'xx'               option ssid '🐌 Amirul'\''s Residence - 2.4GhZ'
option network 'lan wan wan6'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11a'
option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option txpower '20'
option htmode 'VHT80'
option channel '128'
option country 'SG'
option cell_density '3'
option noscan '1'

config wifi-iface 'default_radio1'
option device 'radio1'
option mode 'ap'
option encryption 'psk-mixed'
option key 'xx'
option ssid 'Amirul'\''s Residence - 5GhZ'
option network 

yes done it works now can you help me on why the 5ghz ssid wifi name isnt showing on my mobile wifi

fwiw, does your mobile device support 5 GHz?

What is the make/model ?

yup it sure does it used to show when it was on original xiaomi firmware


Samsung A52 5G 2021

Singapore is not listed in the Wikipedia article I posted above on WiFi channels.

However, 128 is a DFS (radar) channel in most countries.

Pick one that isn't.

Yes done i set the 5ghz channel to 161 and it shows now

Can you tell me how to use https on luci panel?


Set option redirect_https '1' in /etc/config/uhttpd

Doesnt work as expected

It's a self-signed certificate, so you'll get the warning.

any way to remove it?

You would need a certificate signed by a CA.

so how can i get it for free btw i saw some pre installed certificates from httpd