No WIFI signal

It is the same behavior with WPA2 - thanks

And what do the system and kernel log show? You can access them both thru Luci.

I have set the buffer to 512 so can not post all of it

45161.733813] ieee80211 phy0: change: 0x40
[245161.954005] ieee80211 phy0: change: 0x60
[245162.174195] ieee80211 phy0: change: 0x40
[245162.394389] ieee80211 phy0: change: 0x40
[245162.614576] ieee80211 phy0: change: 0x40
[245162.834766] ieee80211 phy0: change: 0x40
[245163.054956] ieee80211 phy0: change: 0x40
[245163.275147] ieee80211 phy0: change: 0x40
[245163.495338] ieee80211 phy0: change: 0x40
[245163.715524] ieee80211 phy0: change: 0x40
[245163.940394] ieee80211 phy0: change: 0x40
[245164.166010] ieee80211 phy0: change: 0x40
[245164.386245] ieee80211 phy0: change: 0x60
[245164.596474] ieee80211 phy0: change: 0x40
[245164.826725] ieee80211 phy0: change: 0x40
[245165.046974] ieee80211 phy0: change: 0x40
[245165.257195] ieee80211 phy0: change: 0x40
[245165.467426] ieee80211 phy0: change: 0x40
[245165.575554] ieee80211 phy0: change: 0x100
[245165.587596] ieee80211 phy0: change: 0x100
[245165.600754] ieee80211 phy0: change: 0x60
[245165.827814] ieee80211 phy0: change: 0x40
[245166.048051] ieee80211 phy0: change: 0x40
[245166.268288] ieee80211 phy0: change: 0x40
[245166.488524] ieee80211 phy0: change: 0x60
[245166.708761] ieee80211 phy0: change: 0x40
[245166.929001] ieee80211 phy0: change: 0x40
[245167.149234] ieee80211 phy0: change: 0x40
[245167.369469] ieee80211 phy0: change: 0x60
[245167.589703] ieee80211 phy0: change: 0x40
[245167.819952] ieee80211 phy0: change: 0x40
[245168.040184] ieee80211 phy0: change: 0x40
[245168.260418] ieee80211 phy0: change: 0x40
[245168.480648] ieee80211 phy0: change: 0x40
[245168.700884] ieee80211 phy0: change: 0x40
[245168.921118] ieee80211 phy0: change: 0x40
[245169.141361] ieee80211 phy0: change: 0x40
[245169.361579] ieee80211 phy0: change: 0x40
[245169.581809] ieee80211 phy0: change: 0x40
[245169.802041] ieee80211 phy0: change: 0x60
[245170.012272] ieee80211 phy0: change: 0x40
[245170.232491] ieee80211 phy0: change: 0x40
[245170.442710] ieee80211 phy0: change: 0x40
[245170.652927] ieee80211 phy0: change: 0x40
[245170.863149] ieee80211 phy0: change: 0x40
[245170.971273] ieee80211 phy0: change: 0x100
[245170.983333] ieee80211 phy0: change: 0x100
[245170.996490] ieee80211 phy0: change: 0x60
[245171.223520] ieee80211 phy0: change: 0x40
[245171.443757] ieee80211 phy0: change: 0x40
[245171.673987] ieee80211 phy0: change: 0x40
[245171.904228] ieee80211 phy0: change: 0x60
[245172.124451] ieee80211 phy0: change: 0x40
[245172.344675] ieee80211 phy0: change: 0x40
[245172.574909] ieee80211 phy0: change: 0x40
[245172.795135] ieee80211 phy0: change: 0x60
[245173.015361] ieee80211 phy0: change: 0x40
[245173.235585] ieee80211 phy0: change: 0x40
[245173.455806] ieee80211 phy0: change: 0x40
[245173.676031] ieee80211 phy0: change: 0x40
[245173.906270] ieee80211 phy0: change: 0x40
[245174.126500] ieee80211 phy0: change: 0x40
[245174.356722] ieee80211 phy0: change: 0x40
[245174.586952] ieee80211 phy0: change: 0x40
[245174.817199] ieee80211 phy0: change: 0x40
[245175.047424] ieee80211 phy0: change: 0x40
[245175.267637] ieee80211 phy0: change: 0x60
[245175.477845] ieee80211 phy0: change: 0x40
[245175.698065] ieee80211 phy0: change: 0x40
[245175.908282] ieee80211 phy0: change: 0x40
[245176.118485] ieee80211 phy0: change: 0x40
[245176.338706] ieee80211 phy0: change: 0x40
[245176.446825] ieee80211 phy0: change: 0x100
[245176.458865] ieee80211 phy0: change: 0x100
[245176.472028] ieee80211 phy0: change: 0x40
[245176.699061] ieee80211 phy0: change: 0x40
[245176.909278] ieee80211 phy0: change: 0x40
[245177.017389] ieee80211 phy0: change: 0x100
[245177.029423] ieee80211 phy0: change: 0x100
[245177.042570] ieee80211 phy0: change: 0x42
[245177.218718] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[245485.619980] ieee80211 phy0: change: 0x40
[245485.727977] ieee80211 phy0: change: 0x100

Well, there just isn't enough information there to say whether you were hacked at all or not.

It would be a good idea to bump the buffer size up. Also, post both logs, just not one. The system log and the kernel log are both available via Luci, but they are separate things there.

Also, just for completeness, post your WiFi-settings in /etc/config/wireless as well. Remember to remove your password from it, though, before posting.

Great WereCatf
5 min ago a was looking at system log and it was OK now looks like this !!!! ????

UPS ... reason is I changed the buffer size ... where are the log files placed ?

OpenWrt doesn't save the logs, they live only in RAM.

Here is the wireless file:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option band '5g'
	option htmode 'VHT80'
	option country 'FR'
	option cell_density '1'
	option channel 'auto'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'
	option country 'FR'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'something'
	option key 'something'
	option network 'wan wan6'
	option ieee80211w '0'
	option encryption 'psk2'
	option disabled '1'

The thing is that the radio stoped working in version 19 of WRT (without me doing anything) and I have the same problem after update to ver. 21. So either the router is broke or hacked.

If there is a tool which can tell if router radio works I'll be glad - thanks :slightly_smiling_face:

There is no such a thing. The hardware may look like it's working perfectly fine to any software-based tool even when the hardware is broken. There is no mechanism for the hardware to tell any software-based tool "hey, I am broken!"

Get your point

More info about behavior:
When I try to log on the router from Android client, the android is starting log on procedure (finding SSID, asking for password) and it comes up on "associated stations" in Luci BUT andoid is only saying "connecting" and does NOT get a connect before attemp is terminated.

Also .. the radio 0 can perform a "scan" ... does that not indicate that radio is OK ?

No, not necessarily. The scan-function only receives a signal, it doesn't transmit anything, and if the hardware had gone bad and e.g. randomly crashed when trying to transmit something, that scan-function would not reveal the issue.

Sounds like you're considering that the device may have a hardware fault. Here's what I'd recommend: install the stock (vendor) firmware and see if the 2.4GHz radio works properly. Yes, the vendor firmware is almost certainly less secure than OpenWrt, but this is a test to find out if the hardware is working properly.... if the vendor firmware doesn't bring this back to life, you've got a hardware failure.

A hardware failure would also explain slow speeds and other issues that you have experienced, and it is a far more likely reality than a concerted hacking attempt.

You said something about "WiFi calibration-settings" ... is it possible to get a listing ?

OK ... I´ll consider that solution

User guide says:
you MUST STRIP the original OEM firmware before using it with mtd, otherwise YOU MAY BRICK YOUR DEVICE

What does this operation involve - thanks

Well I seem that the 2.5 GHz radio works so .... radio 0 properly just dead .... I saw something about a homepage where you can see must visited/downloaded WRT sw ... do any of you know the address

AND any suggestions for new router :slightly_smiling_face: :sun_with_face:

Lets close the case here ... thanks to all for help :slight_smile: :sun_with_face:

Krazeh,
I hope I am not imposing (sorry Elmo) for interrupting your post. I am new to open forum and not the most tech savy but not able to figure some out.
Krazeh you seem to be super savy (mad jealous) with alot of this and especially the wire guard tunnel stuff.
I'm trying to set up my network on my mac mini server and allow my kids to remote into the home setup for stuff on the server.
I was able to get the tunnel set up and connection is green on both ends but I can't access anything. No data passing. I think it is something to do with the IP of my internet versus the IP of my server....any chance you could help me out?

@KTCG - because your question is not related to this thread's topic, please start a new thread. I'm sure there will be people who would be happy to help there.