No Wifi interface Pine A64+

Hello folks,

received my Pine A64 + and installed openWrt 19.07.6 on it. Connected my Ralink RT5572 usb adapter and booted. I can login to Luci over the ethernet port. Luci shows only wan interface with eth0, NO wifi interface.I can ssh into the device. iw, lsusb etc. commands not found.
Output of "dmesg" after disconnecting/connecting the wifi adapter:

[ 1181.038761] usb 3-1: USB disconnect, device number 3
[ 1184.211368] usb 3-1: new high-speed USB device number 4 using ehci-platform
[ 1184.427597] usb 3-1: New USB device found, idVendor=148f, idProduct=5572
[ 1184.434350] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1184.441503] usb 3-1: Product: 802.11 n WLAN
[ 1184.445691] usb 3-1: Manufacturer: Ralink
[ 1184.449697] usb 3-1: SerialNumber: 1.0

Any suggestions?

opkg update
opkg install kmod-rt2x00-usb kmod-rt2x00-lib kmod-rt2800-usb kmod-rt2800-lib

1 Like

Hi @frollic
How to update without internet connection? I have only lan interface connected to my laptop.

well, you're here, so you have some kind of internet access ?

you can always store the packages on a flash drive and move them that way.

1 Like

yes my laptop has internet but how to give excess to the openwrt device over lan?


that's not an openwrt question :wink:

connect the pine and laptop using cable, then set up a bouncer, or proxy on the laptop.

Not sure if it only works via WiFi:

Sorry, but I cant manage to connect to internet. I also did not find an explanation or download source to install the required packages manually. Could someone please explain how to do that? (I can remove the SD card and copy the package directly)

I read that the Ralink RT5572 is supported out of the box, so I don't understand why it's not working :frowning:

Last resort is to by an usb->ethernet adapter. Can someone recommend one which is certain supported out of the box in 19.07, otherwise I would be in the same troubles ones again!

Thanks in advice, gueni

In that case, yes, DL the packages you require, put them on the SD card, and put it back into the Pine.
Then install using opkg.

Out of the box doesn't mean it comes with the image, it means it's supported by the platform.

You already have an ethernet port, why would you need another one ?

I manage to install with setting lan to client and connected it to my main router.
I do have radio now, but radio0 shows "Device is not active" and "Wireless is not associated"

nano /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd8a:a691:829d::/48'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'
        option type 'bridge'

nano /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/1c1b000.usb/usb3/3-1/3-1:1.0'
        option hwmode '11g'
        option channel '1'
        option htmode 'HT20'
        option country 'AT'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'GAP5'
        option network 'lan'

Edit: Wifi scan works. It's possible I need "hostapd" to solve?

are you using cli only ?

opkg update
opkg install luci

to get the web interface up and running.

No, I use Luci already.

Well, I finally solved it. I set the lan interface to dhcp client, connected it to my main router and, following your suggestion, installed:

and finally "hostapd", what solved the "Wireless is not associated" issue and let me set the proper wireless security (AES).

Hurray! Sent over my new OpenWrt router with Wifi AP! :grinning:

@frollic Thank you very much!!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.