No wifi in 18.06 with hg556a

Can you see the following in the System and Kernel logs respectively?

... daemon.notice netifd: radio0 (...): Could not find PHY for device 'radio0'

... pci 0000:00:01.0: invalid calibration data

If yes, the partition mtd5 "cal_data" is corrupted

Next, the steps to follow, from a blog in Spanish:

My router HUAWEI HG556A does not recognize the wifi after loading several firmwares

Actually my cal_data indeed became corrupted. I needed to restore the partition every time I tried to install 18.06, otherwise wifi didn't work even in old versions. I tried three times the new version and restoring cal_data and finally I gave up. I also tried once 18.06.1

Same as me.

I'm drying the night versions, but stay bootta help

I have a lot of 30 gm556A and I have learned a lot of matter however, I have a lot of flash, which is the current time of the rice, the first time I have been in my CIAM 19.01, I do not have a myth on my rigam 19.01 if you have the wi-fixture of the Schansion Chip mode model. İ am sorry english

A simple way to restore call-data partition

Take a look at I have edited the page with new contents, and instruction to restore the cal_data partition.

1 Like

HG556a-C after installing 18.06.2

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00020000 00020000 "CFE"
mtd1: 00020000 00020000 "nvram"
mtd2: 00fc0000 00020000 "linux"
mtd3: 0015b414 00020000 "kernel"
mtd4: 00e64aec 00020000 "rootfs"
mtd5: 00c20000 00020000 "rootfs_data"

HG556a-C 17.01.4

dev:    size   erasesize  name
mtd0: 00020000 00020000 "CFE"
mtd1: 00136e58 00020000 "kernel"
mtd2: 00d890a8 00020000 "rootfs"
mtd3: 00b40000 00020000 "rootfs_data"
mtd4: 00ec0000 00020000 "linux"
mtd5: 00100000 00020000 "cal_data"
mtd6: 00020000 00020000 "nvram"

I can not follow the instructions changes everything and there is no "cal_data"

Neither I work the instructions to recover the WiFi given on the web, it only works for me to be able to return to 17.01.4 without WiFi problems

Hi @Jeronimo17
Do not update, stay on version 17.01.4. If you want to test version 18... download snapshot version, install luci if you want, and "regenerate" the cal_data partition with the instructions on page. It worked for me.

The truth is that I do not want to spoil it again, I tried this version Do you say that the snapshot does the "MTD" appear well?

Short reply: yes
Long reply: I don't remember the snapshot version that I used, but suppose the actual version works too.

@Willy With OpenWrt SNAPSHOT r9860-9385ff6 - Sat Apr 13 07:18:04 2019
And installing with the reset method I have not needed to recover cal_data, but you should clarify on the web that it does not work with the "stable" version

Under "Installation" section you can see this:

Warning: The cal_data partition got corrupted/erased after installing 17.01.6, 18.06.1 or 18.06.2 versions, leaving the wifi not usable for any firmware unless you restore again this partition. See instructions below how to backup and restore the cal_data partition.

I think it should be the opposite, If it has not been specified as a Snapshot version, it is because it is a Stable version.

Hi @Jeronimo17
What version of HG556a have you used? Because my HG556a version B ( HG55VDFA VER.C / HG556BVDFA / 30692) has been bricked with the latest snapshot version.

Ver. A, which uses version C of firmware, but I have gone to Chaos Calmer, which is the one I see most stable, LEDE Reboot 17.01.4 r3560 fails a lot of wifi

Did it really work for you? Because my HG556a version C ( HG55BZRB VER.A / HG556CVDFA / 32505) has been bricked with the latest snapshot version too, same as version B. At least don't corrupt the cal_data partition, so I flashed 17.01.4 again, and then upgrade to 17.01.6, and working again. In the past the snapshot version worked for me, I don't know why it doesn't work now. Where can I get previous versions of snapshot versions to test?

I have solved it partially, in case it serves someone. I tried the latest Snapshot version in all three versions, A, B and C. All of them with version 17.01.4 fully operational bricked. I did many tests without success, until I deleted the partition rootfs_data with the command:

mtd -r erase rootfs_data

Now the wifi works in an A model, it still does not work in the B model, and in two of four of the C model.
How to install the Snapshot version and that the wifi works:
We need a fully functional version 17.01.4.
We delete the rootfs_data partition.
We installed the Snapshot version with the reset method, and that's it.
If you want Luci
Now... Would anyone know how to tell me why delete the rootfs_data partition has only worked with some routers? I'm going crazy.

I killed a modem version of hg556 friends MTD MTD-erased with the erase command will not open jtag now I find I can not help but kuraca notebook PCs have solder please help please I love you greetings from turkey mtd -r erase mtd death


mtd -r erase rootfs_data

This command doesn't brick the router.
Back to 17.01.4 with OEM easy installation, explained on:
And please... give us the "exact" model and serial number.

All MTD wiping device lights not hg556a-A