No webgui after update

Hi all,
I have install the 22.03.3 on fritzbox 4040 and it work.
Today I update this with luci. 2 packages luci - .... git
I can't tell what was the name of the packages.
After the update I can't get the webgui.
How can I undo the update on the console?
Thanks for your help.

Reinstall luci with

opkg update && opkg install luci

1 Like

Tahnk you
This does not work.
On the screen still appears briefly: luci - lua configuration interface
and then in the middle of the screen a rotating circle and the display: loading view....

Is there no way to undo an update?
Where are the packages stored? I can't find that.
Surely one could delete the latest package?...

These are the packages that frollic writes there.
Simply deleting them is not possible because of the dependencies.

It is known LuCI bug yesterday, already fixed. (Accidental commit that was reverted)

But you need to wait for the fixed builds to materialize to buildbot downloads, or build the firmware by yourself.

See an intermediate fix here:

Frollic already linked to that discussion, but just read the command to restore the problematic file from /rom, as the file is included in the flashed image.

cp /rom/www/luci-static/resources/ui.js /www/luci-static/resources/ui.js
Unfortunately this does not help either.

And you did clear your browser's cache?

How exactly did you run your update? Did you use opkg ugrade? Or the LuCI "upgrade packages" option? What upgrades did you perform?

Now I have cleared the cache and it worked immediately.
What was wrong with the cache that it did not work?
thanks a lot

Browsers are sometimes weak in detecting changed JavaScript files.

1 Like

Having the same issue here. Fixed it by:

1 Like

This worked just now for me too!

Didn't work here

Thank-you to all who do hard work here, and I get that mistakes are made - that is not a problem at all. But this should have been an announcement. Not left for people to find out by wandering into.

Pull the bad package off the servers now and revert it to the last known working one.

This worked for me also. It took me several days to find this solution having thought it was something I had done!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.