No WAN Connection - Full dedtails

Updated my router OPEN WRT FW yesterday and since then I have been unable to get any WAN connection working.
Here is the set up
Internet: Virgin SuperHub 3 in Modem mode (DHCP disabled)
Linksys WRT 3200ACN with latest OpenWRT installed
Hub to Linksys is using the linksys WAN port
Virgin hub IP

Here is a pic of how everything is set up (sorry limited to 1 image so had to combine it)

Please any help or input is appreciated as its driving me mad

Hello and Welcome.

If your internet is coming form a modem or a modem-router in modem mode, then you need to configure your OpenWrt WAN interface to PPPoE (or whatever the type of connection you have -- simply the same settings that were in your SuperHub before you changed it to modem mode).

By the way, it's a good privacy practice to redact your MAC addresses and any static public IP you may have when you share your info.

1 Like


Good point on redacting the private info! Will remove the pics if I get it working.

I'll try the PPPoE settings. I read elsewhere that Virgin Media use a DHCP setting but I'm going to try that.

Its Cable internet BTW and the router (in modem mode) handles all the connection

Could it be that Virgin require you to copy the MAC address of the modem to the router?

Also did you change any of the default settings in OpenWrt (apart form the admin password and the WiFi settings? If so, please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall