No RX for Mullvad WireGuard Client

Hi, I'm trying to setup wireguard on my Fast Rhino R68S router running Openwrt R24.02.19(had also tried version R22) using Mullvad and following their guide. However, after setting up everything, there is no RX, only TX, and no internet. I've searched and couldn't find a solution on my own, so I'm hoping someone could point me to the right direction on how to fix it. Not sure if it matters but I'm running it from China, both my laptop(macos) and android device can access the same servers without any issue.

Here is my Network settings:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdd1:6f46:f2e8::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0 eth2 eth3'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.100.1'

config device 'lan_eth0_dev'
	option name 'eth0'
	option macaddr 'be:0c:7a:9c:c4:33'

config device 'lan_eth2_dev'
	option name 'eth2'
	option macaddr 'be:0c:7a:9c:c4:33'

config device 'lan_eth3_dev'
	option name 'eth3'
	option macaddr 'be:0c:7a:9c:c4:33'

config interface 'wan'
	option ifname 'eth1'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'XXXXXXXXXXXXXXXXX'
	option password 'XXXXXXXXXXXXXXXXX'
	option ipv6 'auto'
	option keepalive '0'
	option metric '20'

config device 'wan_eth1_dev'
	option name 'eth1'
	option macaddr 'XXXXXXXXXXXXXXXXX'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config device
	option type 'bridge'
	option name 'docker0'

config interface 'WGINTERFACE'
	option proto 'wireguard'
	option private_key 'XXXXXXXXXXXXXXXXX'
	option metric '10'
	option force_link '1'
	list addresses ‘X.X.X.X/32'
	list addresses 'XXXXXXXXXXXXXXXXX'
	option delegate '0'

config wireguard_WGINTERFACE
	option route_allowed_ips '1'
	option endpoint_port '51820'
	list allowed_ips '0.0.0.0/0'
	list allowed_ips '::0/0'
	option public_key 'XXXXXXXXXXXXXXXXX'
	option endpoint_host 'X.X.X.X'

Firewall:

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Thanks for the info. There is no official support from Openwrt for the router. This is the firmware I've used(RockChip): https://github.com/haiibo/OpenWrt

I doubt it's the firmware issue though. Just wondering if there is any obvious config issue I've missed

the end quote looks weird, but it might be a C&P error ?

1 Like

I've seen such copy-paste errors when using mac.

Oh yes, sorry, that was definitely c&p error :sweat_smile: