No rule to make target 'package/isc-dhcp-server-ipv6/compile'


I'm trying to build isc-dhcp-server-ipv6.

I followed this guide:

I have

- Installed build system
- ./scripts/feeds update -a
- ./scripts/feeds install -a 
- make menuconfig
=> selected isc-dhcp-server-ipv6 <M>
=> save
- ./scripts/feeds install isc-dhcp-server-ipv6
- make tools/install
- make toolchain/install
- make package/zlib/compile V=sc

no problem so far ...

make package/isc-dhcp-server-ipv6/compile V=sc
make[1]: *** No rule to make target 'package/isc-dhcp-server-ipv6/compile'. Stop.

isc-dhcp makefile

Many thanks in advance for your help.

Kind Regards

Probably just make package/isc-dhcp/compile V=sc and it should build the selected sub-packages like isc-dhcp-server-ipv6

Base on the Makefile declaring itself as PKG_NAME:=isc-dhcp


So so many thanks for your answer.

I trying to built it because this package lead to a segmentation fault on OpenWRT 19.07.2 but was working well on 18.06.2

I have tried a few methods
Using isc-dhcp according to your advice or using isc-dhcp-server-ipv4 or isc-dhcp-server-ipv6 ....

I have search about No rule to make target and I have read on the forum that sometimes you need to use explicit package name instead the variable one. Question: One makefile for multiple packages - No rule to make target

But each time regardless of package name (isc-dhcp, isc-dhcp-server-ipv6) using explicit package name (feeds/packages/net/isc-dhcp, packages/net/isc-dhcp) that I'm using I always have a No rule to make target 'feeds/packages/net/isc-dhcp/compile' or whatever target I can try (clean, compile, prepare, check, build ....)

To test, I successfully built other package as chrony with the same build system. I tried to rebuild from scratch the environment 2 times but always No rule to make target 'feeds/packages/net/isc-dhcp/compile'

the third rebuild of build system is underway.

Kind Regards

Works for me on 19.07 build system for ipq806x.
I selected just <M> isc-dhcp-server-ipv6 and compile works quite ok, and the .ipk package gets created.

perus@ub1910:/Openwrt/r7800-1907$ ./scripts/ 

perus@ub1910:/Openwrt/r7800-1907$ grep isc-dhcp .config
# CONFIG_PACKAGE_isc-dhcp-client-ipv4 is not set
# CONFIG_PACKAGE_isc-dhcp-client-ipv6 is not set
# CONFIG_PACKAGE_isc-dhcp-omshell-ipv4 is not set
# CONFIG_PACKAGE_isc-dhcp-omshell-ipv6 is not set
# CONFIG_PACKAGE_isc-dhcp-relay-ipv4 is not set
# CONFIG_PACKAGE_isc-dhcp-relay-ipv6 is not set
# CONFIG_PACKAGE_isc-dhcp-server-ipv4 is not set

perus@ub1910:/Openwrt/r7800-1907$ make package/isc-dhcp/compile
 make[1] package/isc-dhcp/compile
 make[2] -C package/libs/toolchain compile
 make[2] -C package/libs/zlib compile
 make[2] -C feeds/packages/net/isc-dhcp compile

perus@ub1910:/Openwrt/r7800-1907$ ls -l bin/packages/arm_cortex-a15_neon-vfpv4/packages/isc*
-rw-r--r-- 1 perus perus 1089072 huhti  19 20:06 bin/packages/arm_cortex-a15_neon-vfpv4/packages/isc-dhcp-server-ipv6_4.4.1-3_arm_cortex-a15_neon-vfpv4.ipk


Many thanks for your answer.
I hadn't seen it in my 100+ opened tabs :frowning:
I have found yesterday how to successfully build isc-dhcp packages.
For me it works only if I select all isc-dhcp packages as module with menuconfig.
Then I successfully patched isc-dhcp-server-* 4.4.1 with some ISC patch and built it and then updated and build to the last 4.4.2 release but I always have a segmentation fault

Impossible to get DDNS working.
I have no choice but to give up.

Kind Regards