No radio 5ghz in startup - WRT1900acv2

Hi Everyone,

I'm seeking for help to turn on 5ghz wireless radio.

Hostname: OpenWrt
Model: Linksys WRT1900ACv2
Architecture: ARMv7 Processor rev 1 (v7l)
Firmware Version: OpenWrt 19.07.10 r11427-9ce6aa9d8d / LuCI openwrt-19.07 branch git-22.099.58928-786ebc9
Kernel Version: 4.14.275

Log: here I can see the 2.4ghz radio “phy0” in startup but not 5ghz “phy1”

[    8.512986] <<Marvell Mac80211 Wireless PCIE Network Driver version 10.3.8.0-20181210>>
[    8.521037] pci 0000:00:02.0: enabling device (0140 -> 0142)

Currently in /etc/config/wireless has no 5ghz in there. I have tried to manually config wireless to put 5ghz in but the system log said there is no phy1. (phy0 is 2.4ghz)

Thank you in advance,

Welcome to the community.

Aside from using an older and unsupported version of OpenWrt (others might suggest upgrading), I did notice one thing that might be helpful.

Have you tried first just resetting the router to factory default before initial configuration?

1 Like

Thanks for your suggestion

Yes. I have tried remove wireless config to let the system generate new one, as well as factory reset.

I have tried latest openwrt as well as dd-wrt, none of them help (2.4 wifi works well). What I can see here is for some reasons, those firmware seems not to recognise phy1 which is the 5g wifi device.

I have tried with linksys firmware, it’s terrible. No 2.4 wifi (log shows 2.4 ghz mac address is 0). Unstable and slow 5ghz wifi, and funny thing is when i connect to 5ghz wifi, the 2.4 led light is on not 5.

Odd. I run a WRT1900ACS V2 and my 5GHz has always been ‘phy0‘, aka radio0

As @lleachii says, update your box to the current rc2 build as a start. Take a Backup first, and do not save configs. After 19.07.10 you lose your Switch and move to DSA.

enable your wireless.

Don’t change anything else at this point. Post the output of:
uci export network and uci export wireless.

Thank you, RuralRoots

I have followed your suggestion, currently running openwrt-23.05.0-rc2. Please see below for CL queries:

root@OpenWrt:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd42:d02b:84c5::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'xx:xx:xx:xx:xx:'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
root@OpenWrt:~# uci export wireless
package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option country 'AU'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option macaddr 'xx:xx:xx:xx:xx'

OOTB, this should work, but clearly the box is only seeing the 2.4 radio.
Try iwinfo. Don’t need the details. Just tell me what phyx-apx it returns.

Here is iwinfo returns. I just set the password for 2.4ghz wifi as I live in an apartment, don't want leave the wifi public.

root@OpenWrt:~# iwinfo
phy0-ap0  ESSID: "OpenWrt"
          Access Point: xx:xx:xx:xx:xx
          Mode: Master  Channel: 11 (2.462 GHz)  HT Mode: HT40
          Center Channel 1: 9 2: unknown
          Tx-Power: 36 dBm  Link Quality: 66/70
          Signal: -44 dBm  Noise: -95 dBm
          Bit Rate: 216.7 MBit/s
          Encryption: WPA3 SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11b/g/n
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

root@OpenWrt:~# 

Well, the box isn’t seeing the 5G radio. I expect dmesg | grep phy will only return a phy0 response. And, the 19.07 build doesn’t see it either. I suspect you are looking at a hardware issue. Hopefully someone here will chime in, I’m out of my depth on this one.

For the record, you’ve be running an older build on 19.07, when did you first observe that you only have one band working.

On a side note wpa3 doesn’t play well on these boxes.

The issue was found when it was with stock firmware, 5ghz dropping/slowing down couple of times, I then tried restoring, reseting...and also rolling back to old stock firmware, then trying with openwrt. When switching to openwrt for the first time, I saw 5ghz showed up in Luci, but not working, then totally disappear. So yeah, I think it is having a hardware issue. But I'm not sure why the log doesn't show any error about 5ghz?

Anyway, thanks for your time, I appreciate that.

Here is dmesg returns. Yes, it is only talking about phy0.

root@OpenWrt:~# dmesg | grep phy
[    0.000000] Booting Linux on physical CPU 0x0
[    1.218690] ahci-mvebu f10a8000.sata: supply phy not found, using dummy regulator
[    1.769028] usb_phy_generic usb3_1-phy: dummy supplies not allowed for exclusive requests
[    5.225447] mv88e6085 f1072004.mdio-mii:00 lan1: configuring for phy/gmii link mode
[    8.912817] ieee80211 phy0: priv->pcmd_buf = b53134ec  priv->pphys_cmd_buf = a59120ad
[    8.921057] ieee80211 phy0: fw download start
[    9.039285] ieee80211 phy0: FwSize = 118776 downloaded Size = 118776 curr_iteration 65510
[    9.901404] ieee80211 phy0: fw download complete
[    9.901418] ieee80211 phy0: device node: pcie@2,0
[    9.906674] ieee80211 phy0: pcmd = b53134ec
[    9.924421] ieee80211 phy0: firmware version: 0x702091a
[    9.947700] ieee80211 phy0: firmware region code: 0
[    9.983850] ieee80211 phy0: regdomain: FCC
[    9.983857] ieee80211 phy0: Channel: 1: 0x0 0x0 0xf
[    9.983865] ieee80211 phy0: 17 10 10 10 f f f f e e e e 0 0 0 0 
[    9.983869] ieee80211 phy0: Channel: 2: 0x0 0x0 0xf
[    9.983876] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983879] ieee80211 phy0: Channel: 3: 0x0 0x0 0xf
[    9.983886] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983889] ieee80211 phy0: Channel: 4: 0x0 0x0 0xf
[    9.983895] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983898] ieee80211 phy0: Channel: 5: 0x0 0x0 0xf
[    9.983905] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983908] ieee80211 phy0: Channel: 6: 0x0 0x0 0xf
[    9.983915] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983918] ieee80211 phy0: Channel: 7: 0x0 0x0 0xf
[    9.983925] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983928] ieee80211 phy0: Channel: 8: 0x0 0x0 0xf
[    9.983934] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983938] ieee80211 phy0: Channel: 9: 0x0 0x0 0xf
[    9.983944] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983947] ieee80211 phy0: Channel: 10: 0x0 0x0 0xf
[    9.983954] ieee80211 phy0: 18 16 16 16 16 16 16 14 11 11 11 11 0 0 0 0 
[    9.983958] ieee80211 phy0: Channel: 11: 0x0 0x0 0xf
[    9.983964] ieee80211 phy0: 17 12 12 12 13 13 13 13 f f f f 0 0 0 0 
[    9.984443] ieee80211 phy0: 2G enabled, 5G disabled
[    9.989369] ieee80211 phy0: 4 TX antennas, 4 RX antennas
[   12.423195] mv88e6085 f1072004.mdio-mii:00 lan1: configuring for phy/gmii link mode
[   12.557288] mv88e6085 f1072004.mdio-mii:00 lan2: configuring for phy/gmii link mode
[   12.657469] mv88e6085 f1072004.mdio-mii:00 lan3: configuring for phy/gmii link mode
[   12.790586] mv88e6085 f1072004.mdio-mii:00 lan4: configuring for phy/gmii link mode
[   12.911656] mv88e6085 f1072004.mdio-mii:00 wan: configuring for phy/gmii link mode
[   13.195150] ieee80211 phy0: regdomain: AU
[   13.195160] ieee80211 phy0: Channel: 1: 0x0 0x0 0xf
[   13.195168] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195172] ieee80211 phy0: Channel: 2: 0x0 0x0 0xf
[   13.195179] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195182] ieee80211 phy0: Channel: 3: 0x0 0x0 0xf
[   13.195188] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195191] ieee80211 phy0: Channel: 4: 0x0 0x0 0xf
[   13.195198] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195201] ieee80211 phy0: Channel: 5: 0x0 0x0 0xf
[   13.195207] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195210] ieee80211 phy0: Channel: 6: 0x0 0x0 0xf
[   13.195217] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195220] ieee80211 phy0: Channel: 7: 0x0 0x0 0xf
[   13.195226] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195230] ieee80211 phy0: Channel: 8: 0x0 0x0 0xf
[   13.195236] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195239] ieee80211 phy0: Channel: 9: 0x0 0x0 0xf
[   13.195245] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195249] ieee80211 phy0: Channel: 10: 0x0 0x0 0xf
[   13.195255] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   13.195259] ieee80211 phy0: Channel: 11: 0x0 0x0 0xf
[   13.195265] ieee80211 phy0: a a a a a a a a a a a a 0 0 0 0 
[   14.412408] ieee80211 phy0: change: 0xffffffff
[   14.529190] br-lan: port 5(phy0-ap0) entered blocking state
[   14.534794] br-lan: port 5(phy0-ap0) entered disabled state
[   14.540521] device phy0-ap0 entered promiscuous mode
[   14.545571] br-lan: port 5(phy0-ap0) entered blocking state
[   14.551173] br-lan: port 5(phy0-ap0) entered forwarding state
[   14.557136] br-lan: port 5(phy0-ap0) entered disabled state
[   14.567162] ieee80211 phy0: change: 0x100
[   14.575228] ieee80211 phy0: change: 0x42
[   14.732423] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[   14.739152] br-lan: port 5(phy0-ap0) entered blocking state
[   14.744755] br-lan: port 5(phy0-ap0) entered forwarding state
[ 2553.588543] ieee80211 phy0: Mac80211 start BA 9c:b6:d0:e4:14:45
[ 2653.208087] ieee80211 phy0: Mac80211 start BA 3c:15:c2:c3:16:56
[ 2698.019569] device phy0-ap0 left promiscuous mode
[ 2698.024383] br-lan: port 5(phy0-ap0) entered disabled state
[ 2698.184484] ieee80211 phy0: change: 0x40
[ 2698.273311] ieee80211 phy0: change: 0x100
[ 2698.724319] ieee80211 phy0: change: 0xffffffff
[ 2698.823827] br-lan: port 5(phy0-ap0) entered blocking state
[ 2698.829444] br-lan: port 5(phy0-ap0) entered disabled state
[ 2698.835146] device phy0-ap0 entered promiscuous mode
[ 2698.840206] br-lan: port 5(phy0-ap0) entered blocking state
[ 2698.845809] br-lan: port 5(phy0-ap0) entered forwarding state
[ 2698.954695] ieee80211 phy0: change: 0x100
[ 2698.963457] ieee80211 phy0: change: 0x42
[ 2699.066344] br-lan: port 5(phy0-ap0) entered disabled state
[ 2699.122430] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[ 2699.129171] br-lan: port 5(phy0-ap0) entered blocking state
[ 2699.134773] br-lan: port 5(phy0-ap0) entered forwarding state
[ 2788.104042] device phy0-ap0 left promiscuous mode
[ 2788.108942] br-lan: port 5(phy0-ap0) entered disabled state
[ 2788.162891] ieee80211 phy0: change: 0x40
[ 2788.251659] ieee80211 phy0: change: 0x100
[ 2788.702581] ieee80211 phy0: change: 0xffffffff
[ 2788.802101] br-lan: port 5(phy0-ap0) entered blocking state
[ 2788.807716] br-lan: port 5(phy0-ap0) entered disabled state
[ 2788.813417] device phy0-ap0 entered promiscuous mode
[ 2788.818475] br-lan: port 5(phy0-ap0) entered blocking state
[ 2788.824073] br-lan: port 5(phy0-ap0) entered forwarding state
[ 2788.838146] ieee80211 phy0: change: 0x100
[ 2788.847172] ieee80211 phy0: change: 0x42
[ 2789.003577] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[ 3350.974140] ieee80211 phy0: Mac80211 start BA 3c:15:c2:c3:16:56
[ 3694.897840] device phy0-ap0 left promiscuous mode
[ 3694.902668] br-lan: port 5(phy0-ap0) entered disabled state
[ 3695.018560] ieee80211 phy0: change: 0x40
[ 3695.107360] ieee80211 phy0: change: 0x100
[ 3695.560344] ieee80211 phy0: change: 0xffffffff
[ 3695.658868] br-lan: port 5(phy0-ap0) entered blocking state
[ 3695.664494] br-lan: port 5(phy0-ap0) entered disabled state
[ 3695.670223] device phy0-ap0 entered promiscuous mode
[ 3695.675287] br-lan: port 5(phy0-ap0) entered blocking state
[ 3695.680898] br-lan: port 5(phy0-ap0) entered forwarding state
[ 3695.849681] ieee80211 phy0: change: 0x100
[ 3695.858711] ieee80211 phy0: change: 0x42
[ 3695.920411] br-lan: port 5(phy0-ap0) entered disabled state
[ 3696.018410] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[ 3696.025143] br-lan: port 5(phy0-ap0) entered blocking state
[ 3696.030754] br-lan: port 5(phy0-ap0) entered forwarding state
[ 3734.444674] ieee80211 phy0: Mac80211 start BA 3c:15:c2:c3:16:56