No PPPoE connection

Hello i am using trunk r3472 when it boots up no PPPoE connection established my router is tplink wr1043nd v3,i try reset nothing System log it says ....

daemon.notice netifd: Interface 'wan' is now down
daemon.notice netifd: Interface 'wan' is setting up now
daemon.err insmod: module is already loaded - slhc
daemon.err insmod: module is already loaded - ppp_generic
daemon.err insmod: module is already loaded - pppox
daemon.err insmod: module is already loaded - pppoe pppd[2652]: Plugin loaded. pppd[2652]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
daemon.notice pppd[2652]: pppd 2.4.7 started by root, uid 0
daemon.warn pppd[2652]: Timeout waiting for PADO packets
daemon.err pppd[2652]: Unable to complete PPPoE Discovery pppd[2652]: Exit.

Please check your connection. It seems pppd did not receive PADO packets.

Do versions < r3472 actually work? So is this a regression with that specific release or is this simply the first version you are trying? If there is anything wrong with the communication with the upstream PPPoE-"server" you will get this specific error, so this basically can be anything from "cable not connected" to ""server unhappy with PPPPoE client configuration" and that does not give us much to work on...

Best Regards

I try and change many trunk isn't first time.Everything were working ok with pppoe connection...i make just a reboot from Luci interface...and after that it starts this problem...i check cable...when i change my modem/router to make the pppoe connection and LEDE just as dhcp it has internet and the other modem/router succefully establish connection with pppoe.
So the problem is from LEDE side....i reset it to default settings...i change trunk versions and stable....nothing change.

I just flash again rc2 and everything is ok now!!!

How does PPPOE act after the first time it disconnect?

I ask this because with LEDE, every version I tried in the last 2+ months on my 841nd v5, it does this:
a) first time it connects to PPPOE there is no problem
b) navigating on some particular websites (easiest to replicate it is with , but you have to open several pages to make it happen) the PPPOE connection will random drop (it doesn't happen with tp-link firmware)
c) after the connection drops i start to get "Timeout waiting for PADO packets", the WAN led even blinks as it's sending packets but there is nothing actually send on WAN port

a) and b) apply to OpenWRT 15.05.1/14.07, the difference is that after the pppoe connection random drops for unknown reasons OpenWRT is capable to reconnect while in LEDE case it's like the WAN port is totaly stuck and the only way to fix it is to restart it (from lede web interface is enough) (if you make one of the LAN ports act as WAN port in OpenWRT it happens exactly like in LEDE case, it random disconnect and it start saying "Timeout waiting for PADO packets" but it doesn't actually send any PADO packets on that port).

If you look at this old openwrt ticket it kinda describe how to replicate it.
The main problem is what is causing this "No response to xyz echo-requests".

The same 841nd works fine with tp-link firmware so that exclude a hardware/cables issue.

Self-compiled OpenWRT/LEDE or downloaded from OpenWRT/LEDE site made no difference, the problem repeated itself in same way. If it was only me the one connecting to the router wouldn't had been such a big problem but my father pc connects to it and I actually don't have a list with all the sites/ips that are causing the random pppoe disconnect that I see with OpenWRT/LEDE but not with tp-link firmware. Playing moba games and ending up disconnected in the middle of the game is not fun at all... This problem and the fact that I play games makes me unable to use OpenWRT/LEDE on my router.

Logs just say "No response to xyz echo-requests" doesn't matter what value xyz is, i changed that with no impact on the problem. In OpenWRT case i just see in logs how it reconnected, in LEDE case I just see "Timeout waiting for PADO packets" & "Unable to complete PPPoE Discovery" spam in log.

I have a similar problem, but I am not able to reliabliy replicate the conditions...
Using LEDE trunk builds and RC builds on a D-Link DIR-860L (Rev.B) with a Draytek Vigor 130 (VDSL 25 / 5 in Germany) modem for quite some time now, and everything worked quite nice... until some time ago (must be about the announcement time of RC1 of LEDE 17.01), when my line started to drop regularly... no fixed time, sometimes it lasted 4 days, sometimes just 1-2 days.
Only real error I found in System Log was "Timeout waiting for PADO packets".
Sometimes the router reconnects by itself, sometimes I have to reboot it.
I tried compiling the firmware myself, result is the same... not 100% stability.... line drops when the gods feel bored :smiley:
Is there something I can do to help solve this problem?

I can't replicate the conditions..everything works fine untill i reboot it...just a reboot.
When it boots up the problem starts..."Timeout waiting for PADO packets" & "Unable to complete PPPoE Discovery"...i just upgrade to rc2 and the problem disappears!!!!!!I have used many trunk versions it is the first time this problem occurs.

Ok... tried RC2 myself now, problem has not reappeared yet... fingers crossed:)

Nice bro :slight_smile:

I try latest Trunk build...after one day the same problem occurs...revert back to RC.2 and reset to default settings to make it work again.

flashed 17.01 stable today... works very nice so far, I'll keep you posted

Today i flash 17.01 stable....we will see if this problem fixed...if you see any problem...please post here.

I am also facing similar issue. But before anything, let me try to describe my scenario.

My connection is an ADSL connection. I already have Modem + Router (D-Link non-LEDE device). I have a TP-LINK TL-WR841N Wireless Router running LEDE.

Ethernet cable (LAN 1) from D-LINK Modem + Router is connected to the WAN port of TP-Link Router. Under Interface setting, switched protocol to PPPoE and given username and password. The interface shows 0 Rx and Tx packets and the system log is as above.

Is it right, what I am trying to achieve here? i.e two devices with same PPPoE configuration is possible this way?

No, you cannot have two devices as PPPoE clients to the same internet connection, the server will refuse the second connection, or drop the first one. Normally, only the device with the modem will have to stablish a PPPoE connection.