No PPOE wan connection possible on wrt1900acsv2 after package upgrade

Hi,

I kindly need your help for troubleshooting wan connectivity issues.
It started on Friday after i did some package upgrades

Here the ifstatus

 ifstatus wan
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "pppoe",
        "device": "eth1.2",
        "data": {

        },
        "errors": [
                {
                        "subsystem": "pppoe",
                        "code": "CONNECT_FAILED"
                }
        ]
}

and here is the systemlogd

Mon Feb 15 17:43:17 2021 daemon.info dnsmasq-dhcp[2302]: read /etc/ethers - 0 addresses
Mon Feb 15 17:43:18 2021 daemon.err odhcp6c[1836]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Feb 15 17:43:19 2021 daemon.err odhcp6c[1836]: Failed to send RS (Permission denied)
Mon Feb 15 17:43:23 2021 daemon.err odhcp6c[1836]: Failed to send RS (Permission denied)
Mon Feb 15 17:43:26 2021 daemon.err odhcp6c[1836]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Feb 15 17:43:27 2021 daemon.warn pppd[1877]: Timeout waiting for PADO packets
Mon Feb 15 17:43:27 2021 daemon.err pppd[1877]: Unable to complete PPPoE Discovery
Mon Feb 15 17:43:27 2021 daemon.info pppd[1877]: Exit.
Mon Feb 15 17:43:27 2021 daemon.notice netifd: Interface 'wan' is now down
Mon Feb 15 17:43:27 2021 daemon.notice netifd: Interface 'wan' is setting up now
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - slhc
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - ppp_generic
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - pppox
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - pppoe
Mon Feb 15 17:43:27 2021 daemon.info pppd[2363]: Plugin rp-pppoe.so loaded.
Mon Feb 15 17:43:27 2021 daemon.info pppd[2363]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Mon Feb 15 17:43:27 2021 daemon.notice pppd[2363]: pppd 2.4.7 started by root, uid 0
Mon Feb 15 17:43:33 2021 daemon.err uhttpd[1635]: luci: failed login on / for root from 192.168.1.128
Mon Feb 15 17:43:38 2021 daemon.err uhttpd[1635]: luci: accepted login on / for root from 192.168.1.128
Mon Feb 15 17:43:42 2021 daemon.warn pppd[2363]: Timeout waiting for PADO packets
Mon Feb 15 17:43:42 2021 daemon.err pppd[2363]: Unable to complete PPPoE Discovery
Mon Feb 15 17:43:42 2021 daemon.info pppd[2363]: Exit.
Mon Feb 15 17:43:42 2021 daemon.notice netifd: Interface 'wan' is now down
Mon Feb 15 17:43:42 2021 daemon.notice netifd: Interface 'wan' is setting up now
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - slhc
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - ppp_generic
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - pppox
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - pppoe
Mon Feb 15 17:43:42 2021 daemon.info pppd[2461]: Plugin rp-pppoe.so loaded.
Mon Feb 15 17:43:42 2021 daemon.info pppd[2461]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Mon Feb 15 17:43:42 2021 daemon.notice pppd[2461]: pppd 2.4.7 started by root, uid 0
Mon Feb 15 17:43:42 2021 daemon.err odhcp6c[1836]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

and here is the cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd77:314b:33e8::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'pppoe'
        option username 'password'
        option ipv6 '0'
        option password 'password'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

PPPOE works on the stock image but that one sucks
tried also downgrading and upgrading image but still nothing including factory reset.
Also Default settings with DHCP work. No mac filtering from the ISP

Thanks for your help

Never upgrade packages.....

Save your configuration and list of installed packages, reset the device.

Start from scratch.

Hi,

I did, why do you think that i am posting the question here?

Kind regards,
Bogdan

Don't know what you did, except for doing the package upgrade, and fiddling with images, my crystal ball is offline....

Why do you think you're getting the basics back?

Hi,

what do you mean by getting the basics back ?
I got the basics back because i factory reset the device

Regards,
Bogdan

And we were supposed to know this how...?

Not necessary but i need some help with getting ppoe working again on openwrt
That is why we have the logs right=

Regards,
Bogdan