[Solved] No or private or invalid IP,given! Please check your configuration,No update send to DDNS Provider

Your router does not seem to have a public IP address, is it connected directly to the internet, or is there another router that gives you access to the internet?

1 Like
root@OpenWrt:~# uci export network; ip -4 addr; ip -4 ro
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd15:eeab:1949::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'b8:a3:86:61:cf:35'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'wwan'
        option proto 'dhcp'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
11: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.139/24 brd 192.168.1.255 scope global wlan0
       valid_lft forever preferred_lft forever
default via 192.168.1.1 dev wlan0  src 192.168.1.139
192.168.1.0/24 dev wlan0 scope link  src 192.168.1.139
192.168.2.0/24 dev br-lan scope link  src 192.168.2.1
root@OpenWrt:~#

The address you are using as wan is a private and cannot be used for DDNS.

1 Like

tks. I put photos from drive.google that answer your question in a link to the topic post. I put new photo today: https://drive.google.com/drive/folders/1uMu0848ZknqB1p5Kp_y0S4S7Smf8-kYA?usp=sharing

Either you must run ddns on the ISP router, or use another method of detecting wan IP, like url.

1 Like

Incidentally, my problem looks like this(???):

On my home router I use port forwarding normally. Smoothly.

Is there a solution for my case? Use proxy? DMZ? and How should I proceed?

As you can see in image02.1, I am using wwan and not wan. Is that correct? You said: "like url". Could you talk more about that? Where and How would I place this url?

There is no such evidence, your isp router is not behind cgnat and has a public routable IP.

No need to throw words you don't know what they mean.

It is under advanced settings tab of the ddns entry, ip address source option.

Not solved yet. You can see in image04 in link drive.google above

I continue with the same issues from the beginning and my etc/config/ddns not change. This is ok ?

Please paste here the output of uci export ddns
Make sure you are detecting public IP by url.
Also provide the monitoring and debugging output.

1 Like

Your images show that you are under an undesirable double-NAT setup. If you can, I would try to avoid this, get a public IP on the OpenWrt router, and have this issue fixed.

1 Like

root@OpenWrt:~# uci export ddns
package ddns

config ddns 'global'
option ddns_dateformat '%F %R'
option ddns_loglines '250'
option upd_privateip '0'

config service 'myddns_ipv4'
option lookup_host 'neuberfran.dyndns.ws'
option domain 'neuberfran.dyndns.ws'
option username 'username'
option password 'password'
option enabled '1'
option service_name 'dyn.com'
option interface 'wwan'
option ip_source 'web'

config service 'myddns_ipv6'
option update_url 'http://[USERNAME]:[PASSWORD]@your.provider.net/nic/update?hostname=[DOMAIN]&myip=[IP]'
option lookup_host 'yourhost.example.com'
option domain 'yourhost.example.com'
option username 'your_username'
option password 'your_password'
option use_ipv6 '1'
option interface 'wan6'
option ip_source 'network'
option ip_network 'wan6'
option enabled '0'

What about these?

Sorry. I don't know yet How to do this. Can you help-me more to do this
(I can ping to 192.168.1.139 and neuberfran.dyndns.ws in Ubuntu 19.04. This desktop (with Ubuntu) stay in my residencial (isp router) network

I can't ping to 192.168.2.1 (OpenWrt router)

After a dyndns client runs successfully on any machine connected to your network which goes out on the same public IP, the name will be registered to that IP and it's ready to use. This can be as simple as clicking the update button on their web page, assuming your ISP doesn't change IP's frequently.

You don't necessarily have to run a client on the OpenWrt router.

Now to actually accept connections on the public IP you will need to forward port(s) in the main router going to the OpenWrt router and then in the OpenWrt router to the serving machine.

1 Like

You said: in the main router going to the OpenWrt router and then in the OpenWrt router to the serving machine. The first part of this, I do (look photos drive.google above. I have question: How can I do a second part? (using Console option, preferably

Solved !How can I put Solved in post name

See How to mark a topic as [Solved] for a short how-to.

1 Like

in my topic post name don't have pencil behind the topic. I don't know why

Your start posting is too old. As a new user you can edit your postings only for 24h. I have done it now for you.