No luck finding strong USB wireless AP to go with OpenLEDE

#1

First of all, I am a big fan of this firmware for several years now but that doesn't mean I have a clue how it works. The way I seem to make it function is guessing and via pattern matching while copying other's contributions. But here is what I am looking for now:

VERY STRONG AP USB wifi adapter to plug into my GL-AR300M router (see FW V below) and function as a very strong relay repeater.

I've so far gotten the driver kmod-rtl8192cu and all the other required packages installed as required for TPlink TL-WN8200ND V1.1 USB AP adapter but it doesn't work after getting so close. The 8200 would power up and flash the green light on top and then show steady light but it would not communicate Then after hours of research I ran into an odd green colored wiki page I've since lost stating that the WN8200ND is not supported due to issues with rtl8192 while giving a list of other suggested wifi adapters that supposedly work, the only one of them which was also in the external box module format was a TL-WN822N.

I ordered and today when the WN822N arrived I see it is a V5 model and the last model I see supported online with Open/LEDE is V2. Note that the 822 will not even light up like the 8200 nor will it show a active button in the Network Wifi list like the 8200 shows (but won't function thereafter).

So the question is, does anyone have suggestions for getting either of these two access points going with my router? Or if not can you suggest a high power USB wifi adapter to look for that does work? The 8200 was the strongest adapter I've seen for my laptop in some time, so I'd like something similar. I'm running:

LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)

#2

AP support for USB wlan chipset is abysmal in general, both in terms of firmware support and hardware issues (antennas too small/ too close to each other, device overheating during continuous use).

There are only two wireless chipsets that are relatively acceptable in terms of support for AP mode (ar9170 and ar7010/ar9271), both EOL for multiple years - both with rather noticable limitations (number of concurrent STAs limited by the on-device RAM size, etc.) and rather pronounced instability. It's really not going to work to an acceptable level.

If you plan is to defeat the repeater effect, it's a small price to pay in contrast to the very serious stability issues with USB wlan for this purpose. Using multiple VAPs on the same radio is a better solution in practice.

If you have real needs for an additional radio, consider a cheap/ used second router to connect over ethernet - much less pain, if multi-VAP isn't any option.

3 Likes
#3

AWUS036NHA
PL-H5DN-3070

i've tried only awus one

#4

I used to travel with a re-firmwared Fonera and a very bad performing eBay yagi I would set up in my Latin American hotel room to try to pull a signal from the hotel lobby. On this I would setup the virtual adapter to transmit to my PC in the hotel room like you suggest. That worked fairly well outside of the slow performance of the Fonera.

Then as more and more hotels get sold on (have no idea what you call it) the setup where they try to cloak the same SSID and repeat it all over the property well that seems to fail miserably when I am trying to do the same thing in my palm router using Virtual adapters to further repeat a signal that is already greatly screwed up to begin with.

From that massive fail, I started using a couple of TP link WR703N routers LAN to LAN like you suggest and that works for the most part but the problem with those is of course the crappy antenna inside and thus it is almost worthless as a repeater. Then enter the GLinet AR-150 with antenna jacks but the radio in these will nowhere match the reception of one of these USB dipole units attached directly to a PC, in this case like the TP Link WN8200ND.

Thus my logic of trying to get the WN8200ND or something similar working on one of the Glinet palm routers. There's nothing like the the WN8200ND to pull in a distant signal and unless I just can't find a descent yagi antenna for the antenna ports of one of the Gilnets I can't make the radio in any of these small routers come close to the performance that the WN8200ND will show.

Thus my dilemma.

#5
[   25.657076] rtl8192cu: Chip version 0x11
[   25.754070] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
[   25.768013] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
[   25.775145] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   25.776646] usbcore: registered new interface driver rtl8192cu
[   25.872257] ath: EEPROM regdomain: 0x0
[   25.872279] ath: EEPROM indicates default country code should be used
[   25.872288] ath: doing EEPROM country->regdmn map search
[   25.872308] ath: country maps to regdmn code: 0x3a
[   25.872318] ath: Country alpha2 being used: US
[   25.872327] ath: Regpair used: 0x3a
[   25.883192] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   25.888652] ieee80211 phy1: Atheros AR9531 Rev:2 mem=0xb8100000, irq=47
[   25.936181] kmodloader: done loading kernel modules from /etc/modules.d/*
[   40.568358] device eth1 entered promiscuous mode
[   40.578151] br-lan: port 1(eth1) entered forwarding state
[   40.583768] br-lan: port 1(eth1) entered forwarding state
[   40.621106] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   41.617290] br-lan: port 1(eth1) entered disabled state
[   42.257166] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[   43.068545] eth1: link up (1000Mbps/Full duplex)
[   43.516918] br-lan: port 1(eth1) entered forwarding state
[   43.522559] br-lan: port 1(eth1) entered forwarding state
[   44.346944] rtl8192cu: MAC auto ON okay!
[   44.395328] rtl8192cu: Tx queue select: 0x05
[   45.516738] br-lan: port 1(eth1) entered forwarding state
[   47.037957] random: nonblocking pool is initialized
[   47.170357] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   47.974598] wlan1: authenticate with f4:6d:04:f1:65:8e
[   47.980055] wlan1: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded
[   48.002120] wlan1: send auth to f4:6d:04:f1:65:8e (try 1/3)
[   48.013762] wlan1: authenticated
[   48.056902] wlan1: associate with f4:6d:04:f1:65:8e (try 1/3)
[   48.070655] wlan1: RX AssocResp from f4:6d:04:f1:65:8e (capab=0x411 status=0 aid=1)
[   48.078918] wlan1: associated
[   48.082180] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   66.558397] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[  115.817546] rtl8192cu: MAC auto ON okay!
[  115.873001] rtl8192cu: Tx queue select: 0x05
[  116.558637] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
[  117.937436] rtl8192cu: MAC auto ON okay!
[  117.986816] rtl8192cu: Tx queue select: 0x05
[  118.709853] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
[  120.088553] rtl8192cu: MAC auto ON okay!
[  120.137691] rtl8192cu: Tx queue select: 0x05
[  120.862082] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
[  177.530935] wlan1: deauthenticating from f4:6d:04:f1:65:8e by local choice (Reason: 3=DEAUTH_LEAVING)
[  183.258043] rtl8192cu: MAC auto ON okay!
[  183.317821] rtl8192cu: Tx queue select: 0x05
[  184.033468] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
[  185.407058] rtl8192cu: MAC auto ON okay!
[  185.455941] rtl8192cu: Tx queue select: 0x05
[  186.160088] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
[  187.537205] rtl8192cu: MAC auto ON okay!
[  187.584813] rtl8192cu: Tx queue select: 0x05
[  188.315078] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
[  252.346682] rtl8192cu: MAC auto ON okay!
[  252.447454] rtl8192cu: Tx queue select: 0x05
[  254.757108] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  257.766334] wlan0: authenticate with f4:6d:04:f1:65:8e
[  257.771770] wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded
[  257.793087] wlan0: send auth to f4:6d:04:f1:65:8e (try 1/3)
[  257.904829] wlan0: send auth to f4:6d:04:f1:65:8e (try 2/3)
[  258.024847] wlan0: send auth to f4:6d:04:f1:65:8e (try 3/3)
[  258.154753] wlan0: authentication with f4:6d:04:f1:65:8e timed out
[  259.056052] wlan0: authenticate with f4:6d:04:f1:65:8e
[  259.061408] wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded
[  259.082711] wlan0: send auth to f4:6d:04:f1:65:8e (try 1/3)
[  259.194754] wlan0: send auth to f4:6d:04:f1:65:8e (try 2/3)
[  259.304757] wlan0: send auth to f4:6d:04:f1:65:8e (try 3/3)
[  259.414813] wlan0: authentication with f4:6d:04:f1:65:8e timed out
[  260.846360] wlan0: authenticate with f4:6d:04:f1:65:8e
[  260.851717] wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded
[  260.905610] wlan0: send auth to f4:6d:04:f1:65:8e (try 1/3)
[  261.014725] wlan0: send auth to f4:6d:04:f1:65:8e (try 2/3)
[  261.124716] wlan0: send auth to f4:6d:04:f1:65:8e (try 3/3)
[  261.234711] wlan0: authentication with f4:6d:04:f1:65:8e timed out
[  263.036172] wlan0: authenticate with f4:6d:04:f1:65:8e
#6

The TL-WN8200ND (V1.1) will light a solid green light when attached to the GL-AR300M and the adapter can be used to scan local available networks. Good news is that it finds the networks but bad news is that it will not communicate with any of them when the "Join" is selected. See kernel log above dealing with driver.

#7

Finally got my (somewhat) perfect setup configured and working well. Viola, the "super travel repeater"..

HARDWARE USED:

Router - Gli Net GL-AR300M
LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685) (everything works on this release; note that you may want to replace this GLI net altered version of the firmware due the the GLI front end and having to always log in twice and click "advanced" to get to native OpenWRT.

USB wifi adapter:
ALFA AWUS036NHA 802.11n Wireless-N Wi-Fi USB Adapter High Speed
Chipset: Atheros AR9271 (absolute requirement)

Pigtail to connect adapter to antenna:
1 x 8 inch N male to RP-SMA male plug RF Pigtail Cable Jumper RG58 USA

Wifi Yagi antenna:
L-Com-Hyperlink-Technologies-HG2415Y-2-4GHz-15dBi-Yagi-WLAN-antenna-female-NF

Generic camera mini-tripod to mount ther tube yagi antenna

Software:
opkg install kmod-ath9k-htc

Now just save and go. Didn't have to reboot the router, the Radio 1 magically appeared, I clicked "SCAN" to scan available networks, I picked up a local wifi and entered the passcode and boom I was connected. Incidentally tried it with the stock antenna included with the Alfa the signal was 43%, with the yagi the signal was 75%. Other notes, the signal the Alfa picks up is transmitted via the "Master" access point radio and in the case of the GL-AR300M, the two antennas that are provided with this router. Using this setup as a repeater appears to be exactly what I am looking for. For the novice trying this, it is imperative that you get the Alfa with the AR9271 chipset. I found one labeled as such and working well for a reasonable price on eBay, as well as a used L-Com and the low loss RG58 pigtail from US supplier wifi expert.

To use:
The Radio 0 may or may not be set up as the access point SSID for the router (I can't remember). You will ultimately set this up as an access point, set wireless security (e.g. WPA2-PSK) and enter an access password. You may attach to the router now via this radio as per normal operation. Oops, almost forgot you have to get Internet access to the router to download the driver for the Alfa and this can be done via plugging the WAN jack of the GL-AR300M into an existing LAN port of a live router if available or if not, the Radio 0 can be configured temporarily as a "client" instead, the scan button used and you can attach to a pre-existing local area wifi signal by selecting it from the scan list and entering the passphrase which is the wifi password for any other wifi you have the password for in the immediate area. This will allow you to go to the software list on the router and refresh the OPKG list and download the driver for the USB wifi adapter (kmod-ath9k-htc). During this process the PC with a LAN cable attachment would be connected to the GL-AR300M LAN port and the Radio 0 would be configured temporarily as "client" with proper password to the area wifi signal. This is done so that the package can be downloaded. Once kmod-ath9k-htc has been installed, then with the PC connected to the router via LAN cable, reconfigure the Radio 0 for being an access point (or Master) and set up an access password and optionally disconnect the latop LAN cable to the router and connect to the router via the wifi signal (Radio 0). Now once this is done and the kmod-ath9k-htc installed, then in the wireless section of the router configuration panel once the Alfa USB is attached then you should see a Radio 1 appear on the wireless panel in addition to the stock Radio 0 only. The Radio 1 will be the USB adapter you just added and it will be configured in "client" mode and the SCAN button will be used when the yagi antenna is pointed toward the remove wifi signal at a hotel or out the window perhaps at a restaurant offering free wifi service. Now once the SCAN button is pressed and the remote transmitting wifi source is in the list, the JOIN button is used and the password for the remote wifi you are connecting to will be entered. On the next screen you must enter a new name for wwan, such as any name you like, e.g. "wwanAlfa" and then Save and Apply the setting (after creating "wwanAlfa" be sure to check the box to replace it when you get to your next travel destination and new wifi source) . Now the Radio 0 will be transmitting from your Gli-net router in your hotel room to your device and the Alfa USB adapter optionally mounted on a tripod will be pointed to the hotel office or source of wifi signal and you will have a really great repeater in operation.

Note also that as a power cable for the GL-AR300M router I used a special USB cable that was labeled 22 gauge as opposed to to conventional cables that are typically 24 gauge (AWG), attached to a wall USB plug which I knew from testing was supply a full 2 amps. Now for the USB charging cable, the smaller the AWG or gauge number, the thicker the wire which means in this case that the thicker than normal (22 gauge) wire running from my 110V to 5V (2A) wall adapter would be able to provide the full power to the combination of the Gli-net router and Alfa USB plugged into it without having any issues or needing a USB hub and additional power supply as has been suggested in the past. To find the thicker wired USB cables, simply add "22 gauge" to your search for "High Speed USB 2.0 A Male to Micro B Sync and Charge Cables"

Enjoy!

#8

Note that the 8M RAM Gli-net GL-AR150 router at half the price of the GL-AR300M should work just as well but I haven't tested it. Otherwise, not sure how much room is available on the 4M flash model USB routers or if there is enough room for the Alfa driver, but if so, then the T Link WR-703N or similar should work as well, even perhaps the BIC lighter size router such as the A5-V11.

#9

4 MB of flash is already a significant challenge just to get running, even after removing LuCI.

Anything less than 8 MB is a crap shoot as to how long it can be supported. I wouldn't suggest purchasing anything under 16 MB flash and 128 MB RAM, unless you've got some very strong form-factor constraints (such as mains-plug mounting or the like).

1 Like
#10

The 4MB bic lighter size router for around $7US is supported by this group's version of OpenWRT and Luci
http://ofmodemsandmen.com/routers.html

No room for any packages other than the cell modem support. It's a handy replacement to perhaps replace a $200 mifi device with this $7 router and a used cell modem.

#11

Further update: I totally disassembled the Alpha and added a 5V power jack which I would not suggest anyone do unless you are a skilled solderer. I could only find a 5V tap at the power plug as the multi-layered circuit board was mostly covered in green circuit board insulation material. Putting it all back together and adding a separate 5V power supply to power the Alpha I found eliminates all the errors and lock ups I was seeing when using this setup in the past. If going this route, however, be sure to inject the additional power supply as close to the Alpha as possible; you might be best putting a very short extension cable in front of the Alpha and splicing into the jumper power wires and injecting the 5VDC there.

Adding supplemental power at the router end (in the previous experiment) via a powered USB hub especially when using a very long USB cable will do you no good; you must insert the extra power very close to the actual Alpha unit. (I would estimate that USB runs even longer than 1' might start to degrade the power level to the Alpha which is the main source of problems with this device.)

After being delighted with the performance of direct power injection, I decided to try my luck with a 15'(5 meter) USB cable while the Alpha was still direct powered from an adapter which surprisingly proved to perform as well as when the short cable and USB powered hub had been tried before. With 5VDC powering the Alpha directly, there was now no lack of performance with even a 15' cable between the Alpha and the router as long as the Alpha has a supplemental power supply. A caveat was that on a power up cycle I had to ensure the router received power a little before or exactly at the same time the Alpha was powered up.

The powered Alpha (when powered from close proximity to it) makes all the difference in the world and with a longer USB cord, this setup (yagi feeding the Alpha, using a long USB cable to connect the Alpha to the router) provides the ability to place the antenna and Alpha at a nice vantage point, perhaps in a window sill at a hotel pointed to the sole router in a hotel lobby for example. This repeater setup is the best I have tested to date. Highly recommended for directional repeating needs and now my perfect travel router setup.

** 72 hrs without a single drop out using this new setup with 15' USB cable no less.

#12

I use a multi hub usb with external power, i have 3 usb adapters working fine... If u want to use multiple usb devices, u can use a multihub with external power, just check if chipset drivers are aviable on package section.

#13

The issue with powered hubs is that the 5VDC once it travels the length of any reasonable length USB cord, the 5VDC voltage drops too low to be used adequately by the Alpha and that is because the Alpha is, compared to other USB devices, an abnormally high current draw.. You see it's not always as people say and that the router does not have the capacity to produce power for the device and it's not that it needs a powered USB hub to resolve the bad USB cable, it is that the device when connected with a typical poor USB cable still cannot access the amount of amps (current) the Alpha needs since the more amps the Alpha attempts to consume, the lower the voltage dips when using ultra thin power wires of USB cables..

For example, the USB cable may be designed with 32 AWG power cable and when the USB power portion is loaded down with a 0.5A being drawn by the Alpha, there is a severe voltage drop at the Alpha and this is because the Alpha needs a great deal of current and typical USB cables are not capable of providing it.. Per the website calculator.net, a 10' USB cable with 32AWG power cable would lose a whopping 32.8% of the 5V when the device on the end of that 10' cable is demanding 0.5A.

The key for anyone having issues with this device is to splice directly into the USB cable within a few inches of the Alpha if your cord is over 2' and supply the duplicate power source as close to the Alpha as you can get.. In contrast, inserting an additional power supply at a hub hanging on the router will likely be too far from the Alpha - you need the power source right next to the Alpha, not strapped on the router and feeding the same flimsy USB cable that the router failed to provide the proper current to the Alpha with.

1 Like
#14

donejuane you might be correct if decided to complicate so much, but for the sake of simplicity i put 50cm LMR cable from ALFA to directional antenna and 50cm USB cable from ALFA to TP-LINK router. this is the current uptime:

#15

Yes, basically this is what I was trying to say in a nutshell, that a short cable was the solution as confirmed with the initial round of testing a few months ago, with this Alfa on a very short USB cable and working well.. Today's refresh of the topic was only to show how the cable can be as long as any conventional USB cable typically used for a non remotely powered device (if so desired). By disassembling the Alpha and installing a DC power outlet on it or by simply splicing into the USB cable a few inches (cm) from the Alfa and injecting power, an individual can be free to choose the needed length of the USB cable they desire (no longer limited to 50cm or less.)..