I have two AX3600 routers where the secondary is connected with wireless bridge mode.
Main router has management IP 192.168.254.1 and secondary 192.168.254.2. Today I tried to upgrade the second router and before doing this, took a backup of the system in Luci.
After the sysupgrade both Luci and SSH didn't connect anymore over 192.168.254.2. Luci makes sense as it was a snapshot upgrade but SSH got me puzzled. I reset the device, got connected over SSH and restored the config... again the same issue. Then I flashed back the previous openWRT version and restored the config, still no SSH. Meanwhile the router/bridge is working fine, I just can't manage the device anymore.
Pinging 192.168.254.2 returns: Destination port unreachable
network config:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd43:2b22:bf23::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'wan'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.254.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.254.1'
list dns '45.90.28.191'
list dns '45.90.30.191'
Yeah I can reset and SSH to 192.168.1.1 then install Luci and do a config restore but after that Luci/SSH is not working anymore while the config (bridge setup etc) is working fine otherwise.
I fixed this problem a while ago by re-flashing the factory image, which was a pain in the butt. (back to stock and tftp factory image). After that I could restore and everything worked again.
Treat this as a last resort option if everything fails
restore from backup only:
/etc/config/network
/etc/config/wireless
reboot secondary router
re-change your lan connect
suppose:
from this document:
Disable DHCP for the LAN interface (as it does prevent relayd from working). Click Save.
Removing redundant WAN interface and firewall zones (Optional)
Installing relayd package
Just make sure that your PC has the IP address from the same subnet as your router, at any given moment.
It can be tricky when you change the subnet of the router from 192.168.1.x to 192.168.254.x
Restoring config should fully work. But only if the backup is made from the same OpenWrt major version release as the new firmware. Restoring a backup made from 21.02 into a new 23.05 may be problematic etc. (but even that mostly works. but there can be config changes rendering incompatibility for some routers)