No libpthread on target and sdk


I have some trouble to compile a custom package for lede. I have cloned and configured the sources, after the build I tried to write my own package Makefile without success ... (no target for compile -- for hours ...)

Then I have setup an overlay and tried to build the sources directly. After an hour a linker problem occured that libpthread is missing. Ok ... searched opkg ... installed libpthread (saying it is installed already).

find / -name "*pthread*.so" => no result !?!?

Also no result in the sdk ... but it is marked to build.

Any ideas?

Best regards

HI, which SDK did you use exactly?

First I have used the current git master and this one lede-sdk-17.01.1-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64.tar.xz

I have a TP-Link WDR4300 as target.

ok stupid mistake ... the file is name .so.0 so "find / -name "*" will match.

BUT there is still no on my target and the package "libpthread" is installed.

this file is below ./staging_dir/host/lib/ seems to be a x86_64 from the host
Any ideas how to build nodejs for lede? The provided package doesn't work (Invalid Argument from node and npm)