No Lan Adapter-connection after bricking router TP-Link

Hi guys, I have a question. I wanted to reset a router type TL-WR1043ND v1 from OPENwrt to factory new. Unfortunately I bricked it, so now WAN+Lan ports are glowing/lighting green. I can't get a LAN connection to it anymore. When I connect a router with a lan cable to pc, the lanadapter shows "unplugged" with a red X instead of identify network. I would like to use the TFTP method to flash it again.
The 8 - 10 reset isnt working too.


Hi, Jeff, thanks for your quick answer. What I don't quite understand about the TFTP method is that it works even though it is displayed in the Lan connection: Unplugged Cable? I already tried to assign an IP manually, but the adapter still shows unplugged :-(. Normally it should come: Unidentfied network or?

Your router is bricked, you will not get Internet, therefore the Windows connection test will not work - ignore it.

Proceed to setup TFTP and re-flash your router. FOllow the Firmware Flashing instructions @jeff linked.

Follow the instructions to enter TFTP mode.

Yes ok, but i do not want to connect to the internet. I want to reach the following network message:

Otherwise, it won't be possible for tftp to establish a connection if he can't get a lan connection to the router, will it?

Ignore it; or use a Linux LiveCD so you are not distracted!

I understand the statements regarding the Windows notification icon; please ignore that icon! That message is not based on anything available during the TFTP process. You need to get an Auto MDI-X connection (Layer 2) to the interface, that's all. The "Unidentified network" icon is based on Layer 3 tests.

Also, your picture is of WiFi, it needs to be a wired connection.

Try the WAN port for TFTP if the LAN ports don't work.

If you configure your computer with a static/fixed IP of (assuming that is the address that the TP-Link will look for) and plug it into a LAN port of your router, it hopefully will just "magically" work. Yes, Windows will complain that you can't reach the Internet, but that's expected.

What should happen is

  • The TP-Link modem starts to boot and "sees" that you're pressing the reset button
  • It switches to firmware-download mode and sets its LAN port to (or something like that)
  • It "asks" if there is a host on the network with the address
  • Your computer says, "yes, here I am with
  • The tftp client in the router connects to your tftp server
  • It asks to download the firmware by its special filename
  • Your tftp server starts sending the file (hopefully you don't need to do anything with buttons or commands with your tftp server)
  • It checks the file it received, flashes it to itself, then reboots itself

Once you've done it once, it becomes a lot clearer and less "scary".

and your device is recent enough (circa 2011, v1.8+)

might be something to check if it doesn't.

If you've got challenges, installing wireshark may help. Windows installers are available. We can give more guidance if you've tried it a few times without success to try to figure out why not.

1 Like

Ok thank you very much guys for the help. tomorrow i will try it hopefully.

1 Like