No lan access to the internet (Raspberry Pi4)

I installed my Raspberry Pi4 but I can't get my local lan to see the internet.

I have a static lan interface:
Ipv4 address:
Ipv4 gateway: (internet interface)
Ipv4 broadcast:
Unchecked bridge interface (tried it with checked too)
Firewall zone: lan

2nd interface:
Dhcp client - cable modem
Firewall zone: wan

I can run the tools from the luci gui and I can ssh to the openwrt box and access the internet from there.

I can't access the internet from my lan.
I get "From (external ip)... Destination Host Unreachable".
The "Network/DHCP and DNS" settings are all default.

I noticed the "status/overview" page says there are no active DHCP leases yet i have a dynamic ip.
I rebooted too.

Grr, I was getting an ip from my old router.
I unplugged it and now I don't get any ip so I I have to debug that.

I I'm not getting any ips from dhcp.
I ran "dhclient - v" from my desktop and it sends DHCPDISCOVER on 255.255. 255.255 255 port 67 but doesn't get a response.
I can set a static ip on my desktop and ssh into the Pi.

I finally got a static ip/dns on my desktop inside my lan resolv and go to external websites.
I don't have DHCP working (the request doesn't even get to the dhcp server :-().

Do you have a USB Ethernet on the PI or just the one built in? if Just the one built in Ethernet do you have a smart switch and VLANs set up for WAN and LAN?

I have USB3 internet and a regular switch (that makes my lan vulnerable to eastern European hackers).
I am using my old router for it's wifi. I want to buy a USB3 wifi adapter so I can retire my old router.

Do you know how to swap eth0 with eth1?

I'm curious to measure the bandwidth of the driver for the USB3 ethernet adapter.

Let me understand better, you have:

ISP device ----> RPi USB Ethernet ----RPi4 ---- Built in ethernet ---- Dumb switch ---- old router as dumb AP

is that about it?

That's it.

What is the network numbering of the ISP device? Does it clash with ?

1 Like