No IPv6 route? with a clean install

I have a main router with openwrt. The setup in it is as downloaded from, with a few packages related to monitoring (e.g. prometheus).

I see IP v6 being assigned by the ISP and IP v6 within the lan. I can talk to computers within the lan with IP v6, however, I can't connect to sites on the internet via IP v6. It is like if the IP v6 routing is missing.

root@openwrt:~# ip -6 route
2600:8800:7280:368::/64 dev br-lan  metric 256  expires 0sec
2600:8800:7280:368::/64 dev br-lan  metric 1024 
unreachable 2600:8800:7280:368::/64 dev lo  metric 2147483647 
fdbb:da2:5d7::/64 dev br-lan  metric 1024 
unreachable fdbb:da2:5d7::/48 dev lo  metric 2147483647 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth0  metric 256 
anycast 2600:8800:7280:368:: dev br-lan  metric 0 
anycast fdbb:da2:5d7:: dev br-lan  metric 0 
anycast fe80:: dev br-lan  metric 0 
anycast fe80:: dev eth0  metric 0 
multicast ff00::/8 dev br-lan  metric 256 
multicast ff00::/8 dev eth0  metric 256 

I see no default route setup. Shouldn't odhcp6c setup those routes automatically?

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; uci export firewall; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru

Never mind,

config interface 'wan6'
    option device 'eth0'
    option proto 'dhcpv6'
    option reqaddress 'try'
    option reqprefix 'auto'
    option defaultroute '0'

I noticed that defaultroute had 0. I didn't set it as 0, so I guess that was the default configuration. I just changed that and everything just began to work.

Now I wonder how can I get openwrt dns to respond to with ipv6 addresses when a AAA record is requested for a lan computer.

# this doesn't give AAA records.
dig server.lan AAA

It's quad-A, not triple-A.

It isn't the default configuration. Maybe some leftover or accidental switching.

Oops. AAAA works :).

Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.