No ipv6 on my vlan interface (only ipv4)

How do I set ipv6 active on my vlan interface? It'w working fine but only ipv4 is "active"

I have no idea what config to edit to add ipv6.

It's about this interface:

config interface 'ziggo_lan'
	option proto 'static'
	option device 'eth0.30'
	list ipaddr '192.168.180.1/24'

/etc/config/network


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdad:b459:8594::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan'

config interface 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '84.200.69.80'
	list dns '84.200.70.40'
	option device 'eth0.10'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '2001:1608:10:25::1c04:b12f'
	list dns '2001:1608:10:25::9249:d69b'
	option device 'eth0.10'

config interface 'vpnclient'
	option proto 'none'
	option device 'tun1'

config interface 'vpnserver'
	option proto 'none'
	option device 'tun0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.20'

config interface 'ziggo_lan'
	option proto 'static'
	option device 'eth0.30'
	list ipaddr '192.168.180.1/24'


uci set network.ziggo_lan.ip6assign='64' ; uci commit network; ifup ziggo_lan

1 Like

That simple :upside_down_face:

Thanks for the help @trendy

My clients not getting a gateway. The system log is telling me this;

Wed Feb  9 22:11:07 2022 daemon.warn odhcpd[904]: A default route is present but there is no public prefix on ziggo_lan thus we don't announce a default route!

What does ifstatus wan6 say?

root@Router:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 40896,
        "l3_device": "eth0.10",
        "proto": "dhcpv6",
        "device": "eth0.10",
        "updated": [
                "prefixes"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2001:1c04:131e:6300::c963",
                        "mask": 128,
                        "preferred": 604799,
                        "valid": 604799
                },
                {
                        "address": "2001:1c04:131e:6300:dea6:32ff:fe9e:b780",
                        "mask": 64,
                        "preferred": 604798,
                        "valid": 1209598
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2001:1c04:131e:6310::",
                        "mask": 60,
                        "preferred": 86399,
                        "valid": 172799,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2001:1c04:131e:6310::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2001:1c04:131e:6300::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 1209598,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::aef8:ccff:fe8f:9efa",
                        "metric": 512,
                        "valid": 1798,
                        "source": "2001:1c04:131e:6310::/60"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::aef8:ccff:fe8f:9efa",
                        "metric": 512,
                        "valid": 1798,
                        "source": "2001:1c04:131e:6300:dea6:32ff:fe9e:b780/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::aef8:ccff:fe8f:9efa",
                        "metric": 512,
                        "valid": 1798,
                        "source": "2001:1c04:131e:6300::c963/128"
                }
        ],
        "dns-server": [
                "2001:1608:10:25::1c04:b12f",
                "2001:1608:10:25::9249:d69b"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [
                        "2001:b88:1002::10",
                        "2001:b88:1202::10",
                        "2001:730:3e42:1000::53"
                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "0017003020010b8810020000000000000000001020010b88120200000000000000000010200107303e4210000000000000000053"
        }
}
root@Router:~#













































You are delegated a /60, which is assigned to lan.
uci set network.lan.ip6assign='62' ; uci commit network; ifup lan; ifup ziggo_lan

That did the trick, thank you again. :wink:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.