No IPV6 Connection

Hello,

Happy new year !!

I recently installed OpenWRT 24.10RC2 on my Flint 2 (Gl-MT6000), I'm in France with the Orange operator.

Internet works perfectly in IPv4.
But I can't get IPv6 to work, I have an address on the wan6 interface, dns ok, etc but no IPv6 connectivity when I run tests...

Wan6:

Thank you for your support :slight_smile:

Firewall Rules:

And Traffic Rules:

I don't see an address. I only see a Delegated Prefix /56...

WHAT tests?! From where?

Please(!) connect via ssh and paste the full output of

cat /etc/config/network
cat /etc/config/firewall
cat /etc/config/dhcp

@Floop741 Please post as text. In the text panel use either 3x backticks

`

Or the button </> in the text format.

Network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'
        option ipv6 '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ip6ifaceid '::bad'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth1.832'
        option reqprefix 'auto'
        option reqaddress 'none'
        option defaultreqopts '0'
        option sendopts '11:00000000000000000000001a0900000558010341010d6674692f656874653771713c1271412e306270422c6c5060293572242b03136790eb836ae043f2f72984683a3b1888d9 15:FSVDSL_livebox.Internet.softathome.Livebox5 16:0000040e0005736167656d 17:000005580006000e495056365f524551554553544544'
        option reqopts '11 17 23 24'
        option noclientfqdn '1'
        option noacceptreconfig '1'
        option clientid '000300011886370F1500'
        option norelease '1'

config interface 'wan4'
        option proto 'dhcp'
        option device 'eth1.832'
        option hostname '*'
        option broadcast '1'
        option vendorid 'sagem'
        option reqopts '1 3 6 15 28 51 58 59 90 119 125'
        option sendopts '77:2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7836 90:00000000000000000000001a0900000558010341010d6674692f656874653771713c1271412e306270422c6c5060293572242b03136790eb836ae043f2f72984683a3b1888d9'
        option norelease '1'
        option clientid '011886370F1500'

config device
        option name 'eth1.832'
        option type '8021q'
        option ifname 'eth1'
        option vid '832'
        option macaddr '18:86:37:0F:15:00'
        list egress_qos_mapping '1:0'
        list egress_qos_mapping '0:6'
        list egress_qos_mapping '6:6'
        option ipv6 '1'

config rule 'policy_direct_rt'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule 'policy_default_rt_vpn'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule6 'policy_direct_rt6'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule6 'policy_default_rt_vpn6'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule 'policy_default_rt_vpn_ts'
        option lookup 'main'
        option priority '1099'
        option mark '0x80000/0xc0000'
        option invert '0'


Firewall

config defaults
        option synflood_protect '1'
        option input 'DROP'
        option output 'DROP'
        option forward 'DROP'

config include 'orange_rules'
        option enabled '1'
        option type 'nftables'
        option path '/etc/nftables.d/nft-prio6-rules.include'
        option position 'chain-append'
        option chain 'mangle_postrouting'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option family 'ipv4'
        list network 'wan4'
        option input 'DROP'
        option forward 'DROP'
        option masq '1'

config forwarding
        option src 'lan'
        option dest 'wan'
        option enabled '1'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        option src 'wan6'
        list src_ip 'fc00::/6'
        list dest_ip 'fc00::/6'

config rule
        option name 'Allow-MLD'
        option proto 'icmp'
        option family 'ipv6'
        option target 'ACCEPT'
        option src 'wan6'
        list src_ip 'fe80::/10'

config rule
        option name 'Allow-ICMPv6-Input'
        option proto 'icmp'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        list icmp_type 'bad-header'
        list icmp_type 'destination-unreachable'
        list icmp_type 'echo-reply'
        list icmp_type 'echo-request'
        list icmp_type 'neighbour-advertisement'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'packet-too-big'
        list icmp_type 'router-advertisement'
        list icmp_type 'router-solicitation'
        list icmp_type 'time-exceeded'
        list icmp_type 'unknown-header-type'
        option src 'wan6'

config rule
        option name 'Allow-ICMPv6-Forward'
        option dest '*'
        option proto 'icmp'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        option src 'wan6'
        list icmp_type 'bad-header'
        list icmp_type 'destination-unreachable'
        list icmp_type 'echo-reply'
        list icmp_type 'echo-request'
        list icmp_type 'packet-too-big'
        list icmp_type 'parameter-problem'
        list icmp_type 'time-exceeded'
        list icmp_type 'unknown-header-type'

config zone
        option name 'wan6'
        option output 'ACCEPT'
        option family 'ipv6'
        list network 'wan6'
        list device 'eth1.832'
        option forward 'DROP'
        option input 'DROP'

config forwarding
        option src 'lan'
        option dest 'wan6'
        option enabled '1'

config forwarding
        option src 'wan6'
        option dest 'lan'

config include 'vpn_server_policy'
        option type 'script'
        option path '/etc/firewall.vpn_server_policy.sh'
        option reload '1'
        option enabled '1'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'HA'
        option src 'wan'
        option src_dport '8123'
        option dest_ip '192.168.1.44'
        option dest_port '8123'

DCHP

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '1'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '5'
        option limit '100'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'server'
        list ra_flags 'none'
        option dns_service '0'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'


Start with removing option reqaddress 'none'.

Do you know / Are you able to use vim on the ssh-session?

After you've removed that line, restart the network with /etc/init.d/network restart.

I use SSH via putty

It's done

What's done? What is working? Is it working? (Try to summarize your issue and your solution if its solved, and mark the thread as solved, please.)

No ..
no I believed it, still no ipv6 on ipv6-test

ON WHICH DEVICE?

On a client, or on the router itself?

Delete all of that.

Delete option family ’ipv4'. Add list network 'wan6'. Restart the firewall (/etc/init.d/firewall reload).

Your wan6 has a PD/56 and IPV6 should just work, but you seem to have modified your default config because you have your wan6 in your lan firewall zone, change wan6 to be in the same firewall zone as your wan4 interface, edit your Lan interface and change IPv6 assignment length under advanced settings to 64

1 Like

Yes if you have a /64 on lan, lan computers get a GUA from within that /64 which is within your routed /56 and the lan computers can forward to the Internet even without a GUA on wan. The GUA on wan is necessary for OpenWrt itself to reach the Internet for example for NTP updates or running a VPN client or server inside the router.

The reason for no GUA on wan was already pointed out, as reqaddress none means not to request one. So much has been changed from defaults here that a lot of things will break. In general the default configuration will work to get a connection with a standards-compliant ISP.

3 Likes

I've just taken the necessary steps and there's still no IPV6 connectivity on my pc and iphone.

Then please show us your current relevant config files, and write down what you have actual tested, and how you have done so! With so much sparse information no one can assist you effectively!

1 Like

look in IPv6 Rules status

.

I followed this tutorial:

As @mk24 had pointed out, you've made a number of changes to your config. Without a clear understanding of all the changes that have been made and why, it's impossible for us to provide any clear input on what the issue could be.

You'd probably be better off, at this point, backing up your current config, resetting the openwrt device to default and then making only necessary changes to get working IPv4 and IPv6 connectivity. Other changes can then be made one by one, confirming connectivity is still good between each change.

3 Likes

yes, I'll reset the router and start from 0

After 1 hours, reseting, and reconfiguring 1 by 1....

It's well done !!!

Thank you for your support