No IPv4 on my TP-Link MR6400 with OpenWrt 24.10.0.rc4

Hi, I'm somewhat new to this, and I'm sorry if I have overlooked the solution to my problem, but I've been searching around, with no luck. Kind of no luck. I've found guides, I've followed them. Everything should be working, but isn't.

As mentioned in the topic, I've got a TP-Link MR6400 with OpenWrt 24.10.0.rc4. I have - of cause - also tried a stable release, but because of the lack of free space on my device, I've got some trouble installing missing packages. Anyway, I'm pretty sure my problem isn't caused by using RC4.

I seem to get an IPv4 address, but the router don't actually use it for anything. I, however, kind of need it. I do get an IPv6. If I set the connection to only IPv4, I get nothing usefull. Hot do I get it to use the IPv4 address, it clearly has?

See screenshot:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# ubus call system board
{
        "kernel": "6.6.67",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7628AN ver:1 eco:2",
        "model": "TP-Link TL-MR6400 v5",
        "board_name": "tplink,tl-mr6400-v5",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0-rc4",
                "revision": "r28211-d55754ce0d",
                "target": "ramips/mt76x8",
                "description": "OpenWrt 24.10.0-rc4 r28211-d55754ce0d",
                "builddate": "1734915335"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd20:6663:2144::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '3 6t'

config interface 'internet'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option apn 'data.tre.dk'
        option auth 'none'
        option pdptype 'ipv4v6'
        option peerdns '0'
        list dns '2a01:4f9:c010:3f02::1'
        list dns '2a00:1098:2c::1'
        list dns '2a00:1098:2b::1'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option band '2g'
        option channel '1'
        option htmode 'HT20'
        option disabled '0'
        option cell_density '0'
        option txpower '19'
        option country 'DK'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'BurningShadow (home)'
        option encryption 'sae-mixed'
        option key '***'
        option ocv '0'
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '10'
        option limit '5'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list ntp '0.openwrt.pool.ntp.org'
        list ntp '1.openwrt.pool.ntp.org'
        list ntp '2.openwrt.pool.ntp.org'
        list ntp '3.openwrt.pool.ntp.org'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name '***.***.dk'
        option ip '192.168.1.2'

config host
        option name 'Server'
        list mac '***'
        option ip '192.168.1.2'
        option leasetime 'infinite'

config host
        option name 'MiniNAS'
        list mac '***'
        option ip '192.168.1.3'
        option leasetime 'infinite'
root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'internet'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Server SSH'
        option src 'wan'
        option src_dport '22'
        option dest_ip '192.168.1.2'
        option dest_port '22'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Server HTTP'
        option src 'wan'
        option src_dport '80'
        option dest_ip '192.168.1.2'
        option dest_port '80'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Server HTTPS'
        option src 'wan'
        option src_dport '443'
        option dest_ip '192.168.1.2'
        option dest_port '443'

See https://openwrt.org/toh/tp-link/tl-mr6400_v5#modem_configuration

1 Like

Not sure how I missed that, but I did.
Thanks a lot :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.