No intranet access via domain name

Fault phenomenon
Suppose the domain name is, the address can be accessed normally on the extranet, and it can also be accessed normally by means of
But if you access on the intranet, then Chmod prompts: ERR_CONNECTION_TIMED_OUT
The intranet access through IP address + port number is normal

Using OpenWrt soft route as the main route
Firmware version: OpenWrt Ipv6-Mini-S2021.08.08 by Sirpdboy / LuCI Master (git-21.211.30217-03784c3)
Kernel version: 5.4.132
Clients are Win10, Edge and Google Chrome, and ipad
Nginx reverse proxy deployed locally
OpenWrt port forwarding is set up

Try this
In OpenWRT-Network-DHCP/DNS-Server settings-Basic settings: 'Rebinding protection' is unchecked
In OpenWRT-Network-DHCP/DNS-Server Settings-HOSTS and resolution file settings: Custom hostage domain name, already bound to IP
Try changing to a different OpenWRT version
Clear browser cache, DNS cache
When accessing on an external network, check the Nginx log file and you can find access logs, but when accessing the same URL locally, Nginx does not have any relevant log information
I tried adding the hostname and corresponding IP address to the network, hostname, and then the intranet access to the domain+IP worked, but the direct access to the nginx proxy's second-level domain was still faulty

You need at least the NAT reflection / NAT loopback config,

See also