No internet on Xiaomi mi4a Gigabit Edition

I have installed OpenWRT , Tried to configure the plan and wan ports, yet the internet is not working, Tried pinging to via ssh but failed.

I flashed it again, but failed to configure it, any ideas?

Have you configured the wan properly? Is it static, dhcp client or pppoe? Can you ping

its static as I am using it as my secondary router . I cant ping .Even if I do , it shows bad connection

Have you set default gateway and dns? Can you ping the upstream gateway or other clients?

Did set getaway and dns , but cant ping upstream getaway or other clients

Try using a different lan cable and try plugging it in the port where the first pc is connected. See if that will change anything.

Welcome to OpenWRT on Xiaomi Router :slight_smile:

  1. Can you connect to your router by SSH?
  2. Can you connect to your router by LuCI?
  3. Have your router got IP for WAN port by DHCP?
  4. From my experience OpenWRT is VERY unstable on Xiaomi routers, I recommend you to install Padavan firmware.

I opened it up and found the whole ports to be burnt due to a chip shortage , so threw it out -_-

Thanks for the people who helped !

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.