No internet on Lan but ok on wireless

Hi everyone.
First Sorry for my English.
I have been trying to resolve the problems whitout results.
Got archer c59. Flash with last open WRT.

RJ45 ISP to WAN c59.
Wireless internet ok. But not LAN.
Thanks for your help

What version of OpenWrt? (eg. 19.07.4)

Does your computer when connected to ethernet LAN, get an IP address from the router (eg. 192.168.1.x)?

Can you access the LuCI web admin UI at default LAN ip address on ethernet LAN? You may have to manually configure a static IP address on the computer.

If you can access the router via wifi, can you post contents of /etc/config/network file to check the 'switch' configuration. (If you are a Windows user, you can use free software called WinSCP to open the file)
Post it here using the "Preformatted text </> " button.


Thanks for your reply.
I'm on Mac osx.
So I found the problems. It was a DNS. When i change to the static IP I put a DNS and
Now I got internet on LAN and wireless.
Verison of open WRT is 19.07 yes.
Now I need to config my openvpn SIP private internet access.
I have been tried pptp and L2TP. Whitout results.
I got connected and IP address or 21 or 5...
But no access to internet.
If can help please.
Maybe TeamViewer it's will be easy to see.
Thanks a lot :+1::+1::money_mouth_face:

You can follow the guide for configuring a vpn client.


If your original problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

If you require further help with VPN, please start a new topic.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.