No internet on LAN although PPPoE connected


I am using an R7800 and have spent all day “learning” and trying OpenWrt for the first time. I switched providers and decided this would be a good time to try more advanced firmware.

I have successfully configured the Router as a “second” router to the main Vodafone router, but I am very unhappy with 2 routers and want to configure the R7800 as the sole router within my network.

I have successfully acquired an IP with PPPoE, and OpenWrt is able to complete TraceRoutes and Pings from within Luci as well as from SSH.

My issue is with “everything else”, my devices on LAN/WLAN can ping each other, but have no internet connection at all. They cannot ping or resolve DNS names.

I typically use PiHole setup on a home server running on, however for the sake of testing this I have returned it all to "factory settings" and trying to get it working with regular DNS first.

My steps "from a factory reset" are, switching "wan" interface to PPPoE and entering my details. This establishes a connection and allows me to ping from the router alone.

The internet from the “Fibre ONT” is connected to the WAN port on the router, and the “remainder” of the ports are all needed for my home network.

I have read countless articles and posts surrounding Firewalls/Nats and everything in between but cannot seem to work this out. Besides the PPPoE setup I have the stock version 22.03.2 r19803.

Any help would be massively appreciated as I am rather desperate to get this fully running.

edit your interface & assign it a firewall zone WAN

What does OpenWrt report as it's upstream IPv4 network? You can find this in the main status page in LuCI. Post just the first 2 octets (in bold: aaa.bbb.ccc.ddd)

I have done this, the lan bridge interface is in LAN zone and the wan interface is in the WAN zone

Connected: (duration)
Device: Tunnel Interface "pppoe-wan"

At this point as previously mentioned IPv4 pings successful from within LuCI

ok... so let's check some additional things for a device on the LAN:

what is the complete LAN IP information for a device that isn't working properly?

  • IP
  • subnet mask
  • DNS
  • router/gateway address
1 Like

Revert the OpenWrt router back the original configuration, then add the PPPoE interface and nothing else; it should work.

1 Like

Okay, I was able to find one of the issues, it appears that 3 of the 4 devices I was using to test were not updating their DHCP's correctly and were referring to an old Gateway. I am SURE I checked this before, but maybe something else was broken at that point, either way it appears to be serving my network "correctly" now.

Onto the next issue, PPPoE speed. When using the second router I was able to get my full 990/110mbps link, but I appear to be topping at about 300mbps down and 110mbps up when using OpenWrt as the PPPoE resolver.

Previously on stock firmware I was getting 500mbps down, so it isn't a physical limitation.

Yup... that's what I was getting at here. This is a common issue if you have devices connected to other APs or switches (beyond the integrated AP/switch in your router) since their connections will not be bounced by the swap of the routers themselves.

I'd recommend that you open a new thread for this topic, since now the main topic has been solved. This will help you get the right eyes on your speed problem questions and hopefully they can guide you to good solutions to improve the overall speed of your connection.

And in that spirit:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

I will do, thank you

Would it be better etiquette to mark "my own" post describing me finding the problem as the solution?

This is up to you -- the goal of marking solved posts is 3-fold:

  1. guide users to the most helpful solution post (sometimes if it is multiple posts, a future user may need to read more for additional context)
  2. close the thread since it no longer needs to be open for comments
  3. give credit to the person who provided the most relevant advice/solution. sometimes this is hard to do because multiple people helped, and that is fine. I see that you have set one of my posts as the solution (thank you)... this is great for my solution count, but ultimately the more important thing is for future readers to be able to learn, so whichever post you think achieves that should be marked as the solution.
1 Like

Given your comment on checking the gateways was what tipped me off, that makes more educational sense to me.

Either way, new post is here: Slow PPPoE Performance vs DHCP-Client

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.