No internet on ethernet ports / Slow transfer rates

Hey guys,

Am using OpenWRT by KONG on a Netgear R7800. (KONG 19 2020-07)

I have 2 wireless radios 2.4g and 5g 20Mhz and 80Mhz respectively

On the Lan port I have an ethernet cable linking to a pc which runs PLEX server. For some reason after the LAN ports do not work and that computer cannot connect to internet.

Notes:
Transfer rates from wifi 5g to Lan are very slow. The led is amber for some reason so it works on 100mb.

There is port forward rule under firewall: DMZ on TCP with source wan+wan6 on external port 32400 with destination zone LAN and internal IP address the computer on lan port 192.168.1.10

Network Config

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdee:f441:b1e9::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

Wireless config

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'CY'
        option channel '36'
        option txpower '23'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'password'
        option encryption 'psk2'
        option ssid 'WIMAX'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option channel '1'
        option txpower '20'
        option country 'CY'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option wmm '0'
        option key 'password'
        option ssid 'WIFI'

Firewall config

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

Dhcp config

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option noresolv '1'
        option doh_backup_noresolv '-1'
        list server '127.0.0.1#5053'
        list server '127.0.0.1#5054'
        list doh_backup_server '127.0.0.1#5053'
        list doh_backup_server '127.0.0.1#5054'

config dhcp 'lan'
        option interface 'lan'
        option limit '150'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option start '50'
        option ra_management '1'
        option leasetime '12h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Looking forward to you help in order to make tha lan port work and make the transfer from wifi 5g to lan faster.

Thank you

Four things:

  • Do you have the correct ethernet cable? Minimum for Gigabit speed is CAT 5e.
  • You should enable WMM Mode on both Radios. For 2,4 GHz you have WMM disabled explicit. For 5 GHz it is not set. That means disabled.
  • Are the rates with 2,4 GHz in range of the expected speed? So only 5GHz is affected?
  • I cannot see your above mentioned firewall rule in Section Firewall config. Please post the full firewall config (uci show firewall). It does not look like default anyway.

What you can do/test:

  • Try other channels. It might be that channel 36 respectively 1 are to crowded due to other routers in your enviromnent.
  • Reduce the Channel width for testing. Go with 40 or 20 to see if sth. changes.
  • Have a look into the logs if there are errors.
  • Test the speed of your server on LAN only. To eliminate the server as a possible bottleneck.

This might help for proper channel selection:

Hello pwned,

  1. Yes the cable is correct is cat6
  2. WMM is disabled on 2.4ghz just to boost the performance
  3. Transfer over 2.4ghz is always slower due to the lower bandwidth

My main issue is the no internet on Lan ports (switch)
Should I flash the original openwrt over KONG release or refresh KONG?

Thank you

Well as long if you have only one client it is O. K.

I know that. :wink: But I want to know if 2,4 GHz is working as it is intended to do.


Your picture is not showing all. Just your specific rule. In addition to this rule you would need a rule opening this port also. But that does not explain why internet is not working.

I'm still missing the output of:

uci show firewall

In addition to that you should post the output of:

nslookup openwrt.org

Well, I've read here already that this guy was active on DD-WRT and he is now doing OpenWrt. But I have to say that his builds are intransparent in terms what he is doing "magically". I think you can have a more transparent build from hnyman:

He is active here on the forum and is giving support for his builds. On top of that you have a wide userbase with this build. So you would know if there is an error in the build itself. Ofc this applies on Vanilla build also. Kong is not giving any support. That is why you are here and asking ... In general helping for custom builds is more difficult than doing that for "normal" builds.

1 Like

I flashed again the image and it seems that problem is solved now, I guess a conflict somewhere. Also now am running on hnyman and so far no problem occured

Concluding the problem is resolved

Thank you

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.