No Internet on Dynalink DL-WRX36

Hi, I have a very strange problem with Dynalink DL-WRX36. I installed OpenWrt on it a few weeks ago and everything was fine. A few days ago I installed the OpenWrt 23.05.3 image(sysupgrade) on it. Because there is still an issue with the LEDs of the wan port when the network cable is unplugged in version 23.05.3, I tried a snapshot image. After that I went back to 23.05.3, but now I do not have Internet. My main router is a Netgear Wax206 with OpenWrt 23.05 connected to the internet via DHCP. When I connect to the Dynalink DL-WRX36 via Ethernet cable or via Wi-Fi I do not have internet on the devices connected to it. I tried different versions of OpenWrt(from 23.05.0 to 23.05.3), but the issue is still there. I did multiple times factory reset, so the router uses its default configurations. The Dynalink DL-WRX36's web interface is accessible, so I can see that the wan has received an IP from the Wax206. The IP of Wax206 and DL-WRX36 are different, so there is no IP conflict. When I open an SSH session to the DL-WRX36 and execute opkg update or opkg install everything is fine, I can ping external sites and I can open/download web pages with wget. When I try to open a website from a device connected to DL-WRX36, I see a connection refused error message in the console of my browser and in the output from wget, but I can access the web interface of the Wax206(via IP). I can also ping(successful) the IPs of external websites and I can see in the web interface of the DL-WRX36 router that packages are passing from Lan to Wan.

/etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2f:5036:8f0f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

/etc/config/dhcp:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

/etc/config/firewall:

config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

but are they using the same LAN side subnets ?

any reason why the WRX isn't a https://openwrt.org/docs/guide-user/network/wifi/dumbap ?

3 Likes

I don't want to use the router as an AP. I want to use it as my main router on another location but now it doesn't work anymore.

If you're using the device as a router, simply change the lan IP to a different subnet. For example, 192.168.6.1. This is necessary because the wan and lan subnets must be non-overlapping.

https://openwrt.org/faq/change_lan_ip

2 Likes

My main router(WAX206) is in another subnet - 192.168.100.x and the DL-WRX36 uses 192.168.1.x therefore there is no IP conflict between both routers. I have other OpenWrt routers at home like Redmi AX6 and with it, I do not have any issues.

Can you show us a system topology diagram? Be sure to label the devices and include the port information so we can see how everything connects.


Here is a diagram of the relevant part of my network.

The Notebook and smartphone do not have internet when they are connected to the Dynalink DL-WRX36. When I connect them to the Asus RT-AX56U which is working as dumb AP, I have internet on the devices. When I replace the Dynalink DL-WRX36 with another OpenWrt router, I have Internet. So the cause of the issue is the Dynalink DL-WRX36 and not my network. I suspect an issue similar to the one on Google OnHub where it was necessary to overwrite the flash with zeros and then flash OpenWrt on it.

Try this: Add DNS servers to the WAN interface

I tried with these custom DNS servers but nothing changed. This was expected for me because when I ping servers like google.com, the IP address is resolved and I also get replies from the server. nslookup also resolves the IPs.

In that case hit the reset button.

As the default IP address is 192.168.1.1 which should not conflict with the main router it should work right out of the box, provided you connect the WAN port of the DL-WRX36 to the LAN port of the main router

All cables are connected correctly. All client devices receive from the WRX36 IP, DNS and Gateway. The WRX36 also receives from my main router WAX206 IP, DNS and Gateway. When I ping a host on the internet from a device connected to the WRX36 the traffic goes through the router(observed also from the web interface of the router), but I still can't open any web page, I get connection refused. I did a factory reset multiple times via the web interface, via the command "firstboot -y && reboot" and via "umount /overlay && jffs2reset && reboot" and nothing helped. I'm thinking to do a F2FS reset, but I do not know how to do it on this specific device. The Wiki of OpenWrt says that I can do a F2FS reset via "dd if=/dev/zero of=/dev/loop0 bs=1M; reboot", but I do not know to what is pointing the /dev/loop0 and there is a risk to delete the bootloader of the device and brick it.

I would just do a sysupgrade with the latest 23.05.3 and not keep settings that should be enough.

As I said, I tried each version from 23.05.0 to 23.05.3 and the latest snapshot. On each flash, I removed the checkbox for keeping my settings. I also did a manual reset a few times, but nothing changed.

Let's see the latest output of the following:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
ifstatus wan | grep address
route

Here is the requested information:

root@OpenWrt:~# ubus call system board
{
	"kernel": "5.15.150",
	"hostname": "OpenWrt",
	"system": "ARMv8 Processor rev 4",
	"model": "Dynalink DL-WRX36",
	"board_name": "dynalink,dl-wrx36",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.3",
		"revision": "r23809-234f1a2efa",
		"target": "ipq807x/generic",
		"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
	}
}
root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.100.1   0.0.0.0         UG    0      0        0 wan
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.100.0   *               255.255.255.0   U     0      0        0 wan
root@OpenWrt:~# ifstatus wan | grep address
		"addresses",
	"ipv4-address": [
			"address": "192.168.100.131",
	"ipv6-address": [
		"ipv4-address": [
		"ipv6-address": [
root@OpenWrt:~# cat /etc/config/dhcp 

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdff:f982:9cd3::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel '1'
	option band '2g'
	option htmode 'HE20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
root@OpenWrt:~# cat /etc/config/firewall 
config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

This should work without issue.

From the router itself, let's see the output of:

ping 64.226.122.113
ping openwrt.org
traceroute openwrt.org

Here is the output from DL-WRX36:

root@OpenWrt:~# ping 64.226.122.113
PING 64.226.122.113 (64.226.122.113): 56 data bytes
64 bytes from 64.226.122.113: seq=0 ttl=53 time=33.671 ms
64 bytes from 64.226.122.113: seq=1 ttl=53 time=33.045 ms
64 bytes from 64.226.122.113: seq=2 ttl=53 time=33.192 ms
64 bytes from 64.226.122.113: seq=3 ttl=53 time=32.985 ms
64 bytes from 64.226.122.113: seq=4 ttl=53 time=33.208 ms
^C
--- 64.226.122.113 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 32.985/33.220/33.671 ms


root@OpenWrt:~# ping openwrt.org
PING openwrt.org (2a03:b0c0:3:d0::1a51:c001): 56 data bytes
64 bytes from 2a03:b0c0:3:d0::1a51:c001: seq=0 ttl=54 time=42.179 ms
64 bytes from 2a03:b0c0:3:d0::1a51:c001: seq=1 ttl=54 time=41.375 ms
64 bytes from 2a03:b0c0:3:d0::1a51:c001: seq=2 ttl=54 time=41.330 ms
64 bytes from 2a03:b0c0:3:d0::1a51:c001: seq=3 ttl=54 time=41.635 ms
64 bytes from 2a03:b0c0:3:d0::1a51:c001: seq=4 ttl=54 time=41.325 ms
64 bytes from 2a03:b0c0:3:d0::1a51:c001: seq=5 ttl=54 time=41.353 ms
^C
--- openwrt.org ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 41.325/41.532/42.179 ms


root@OpenWrt:~# ping openwrt.org -4
PING openwrt.org (64.226.122.113): 56 data bytes
64 bytes from 64.226.122.113: seq=0 ttl=53 time=40.748 ms
64 bytes from 64.226.122.113: seq=1 ttl=53 time=40.743 ms
64 bytes from 64.226.122.113: seq=2 ttl=53 time=41.001 ms
64 bytes from 64.226.122.113: seq=3 ttl=53 time=40.529 ms
64 bytes from 64.226.122.113: seq=4 ttl=53 time=40.667 ms
64 bytes from 64.226.122.113: seq=5 ttl=53 time=40.870 ms
64 bytes from 64.226.122.113: seq=6 ttl=53 time=41.194 ms
^C
--- openwrt.org ping statistics ---
7 packets transmitted, 7 packets received, 0% packet loss
round-trip min/avg/max = 40.529/40.821/41.194 ms


root@OpenWrt:~# traceroute openwrt.org
traceroute to openwrt.org (2a03:b0c0:3:d0::1a51:c001), 30 hops max, 72 byte packets
 1  2a01-5a8-304-270e--1.v6.vivacom.bg (2a01:5a8:304:270e::1)  0.798 ms  0.719 ms  0.597 ms
 2  2a01-5a8--224.v6.vivacom.bg (2a01:5a8::224)  1.864 ms  1.653 ms  1.686 ms
 3  *  *  *
 4  2a01-5a8--1-16.v6.vivacom.bg (2a01:5a8::1:16)  1.737 ms  1.938 ms  1.815 ms
 5  ae40.ams3-edge1.digitalocean.com (2001:7f8:1::a501:4061:2)  37.731 ms  35.931 ms  35.493 ms
 6  *  *  *
 7  *  *  *
 8  *  *  *
 9  *  *  *
10  *  *  *
11  wiki-03.infra.openwrt.org (2a03:b0c0:3:d0::1a51:c001)  42.554 ms  42.114 ms  42.259 ms

Here is the output of a Linux machine connected to DL-WRX36:

ivailo@PC:~$ ping 64.226.122.113
PING 64.226.122.113 (64.226.122.113) 56(84) bytes of data.
64 bytes from 64.226.122.113: icmp_seq=1 ttl=52 time=41.1 ms
64 bytes from 64.226.122.113: icmp_seq=2 ttl=52 time=41.1 ms
64 bytes from 64.226.122.113: icmp_seq=3 ttl=52 time=40.7 ms
64 bytes from 64.226.122.113: icmp_seq=4 ttl=52 time=40.8 ms
64 bytes from 64.226.122.113: icmp_seq=5 ttl=52 time=41.1 ms
^C
--- 64.226.122.113 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 40.729/40.979/41.139/0.176 ms


ivailo@PC:~$ ping openwrt.org
PING openwrt.org (64.226.122.113) 56(84) bytes of data.
64 bytes from wiki-03.infra.openwrt.org (64.226.122.113): icmp_seq=1 ttl=52 time=33.8 ms
64 bytes from wiki-03.infra.openwrt.org (64.226.122.113): icmp_seq=2 ttl=52 time=34.2 ms
64 bytes from wiki-03.infra.openwrt.org (64.226.122.113): icmp_seq=3 ttl=52 time=33.6 ms
64 bytes from wiki-03.infra.openwrt.org (64.226.122.113): icmp_seq=4 ttl=52 time=33.7 ms
64 bytes from wiki-03.infra.openwrt.org (64.226.122.113): icmp_seq=5 ttl=52 time=33.4 ms
64 bytes from wiki-03.infra.openwrt.org (64.226.122.113): icmp_seq=6 ttl=52 time=33.3 ms
64 bytes from wiki-03.infra.openwrt.org (64.226.122.113): icmp_seq=7 ttl=52 time=33.6 ms
^C
--- openwrt.org ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6010ms
rtt min/avg/max/mdev = 33.283/33.662/34.178/0.264 ms

ivailo@PC:~$ traceroute openwrt.org
traceroute to openwrt.org (64.226.122.113), 64 hops max
  1   192.168.1.1  0,236ms  0,222ms  0,222ms 
  2   192.168.100.1  0,933ms  0,768ms  0,813ms 
  3   192.168.100.1  0,849ms  0,832ms  0,833ms

looks like everything on the router is fine, and the linux machine seems fine in terms of the pings, but the traceroute seems to fail (is that all there is??).

Do you have another computer (or phone/tablet) that you can connect to the DL-WRX36? I am beginning to suspect that something is wrong with the computer, not the network.

The problem is not on the computer I'm using. When I connect to the WRX36 via WiFi from an Android phone, I get a notification that there is no internet and I should switch networks. When I connect to the WRX36 from a Windows 11 notebook, the situation is similar. Windows says there is no internet and I can't open a website.

Could you swap the WAX206 and the WRX36 for a while ?