No Internet on Dumb Access Point but other devices can connect to internet

I have 2 OpenWrt device, one as a router (x86), second one as a dumb AP (Xiaomi AX3600)
Everything works fine on other devices in the network connected to the AP, but the AP itself cant connect to internet

I disabled firewall and dhcp on the AP
I also added wan port to lan bridge, and router is connected to ap on that port

Here is config from both devices

root@openwrt-ap:~# uci export network
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd57:1449:18b9::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan.99'
	option proto 'static'
	option ipaddr '10.0.1.2'
	option netmask '255.255.255.0'
	option ip6assign '60'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'wan:u*'

config interface 'guest'
	option proto 'static'
	option device 'br-lan.4'
	option ipaddr '10.0.4.2'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'lan3'
	list ports 'wan:t'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '5'
	option name 'br-lan.5'

config interface 'iot'
	option proto 'static'
	option device 'br-lan.5'
	option ipaddr '10.0.5.2'
	option netmask '255.255.255.0'
root@openwrt-router:~# uci export network
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc1:ca56:8966::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan.99'
	option proto 'static'
	option ipaddr '10.0.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config interface 'vpn'
	option proto 'wireguard'
	option private_key 'removed'
	option listen_port '51820'
	list addresses '10.0.10.1/24'

config wireguard_vpn 'wgclient'
	option public_key 'removed'
	option preshared_key 'removed'
	list allowed_ips '10.0.10.2/32'
	option description 'laptop'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '4'
	option name 'br-lan.4'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '5'
	option name 'br-lan.5'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '99'
	option name 'br-lan.99'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'eth0:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'
	list ports 'eth0:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'eth0:t'

config interface 'guest'
	option proto 'static'
	option device 'br-lan.4'
	option ipaddr '10.0.4.1'
	option netmask '255.255.255.0'

config interface 'iot'
	option proto 'static'
	option device 'br-lan.5'
	option ipaddr '10.0.5.1'
	option netmask '255.255.255.0'

Add default GW and DNS IPs, or reconfigure as DHCP client instead of static IP.

1 Like

Thank you, that worked, i feel so dumb now :sweat_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.