No internet eth2eth unmanaged switch

I have a PI 5 with eth1 usb to the modem, and the other eth going to an unmanaged switch. I think it has to do with the subnet, but im new on this so im unsure on what to do, tried using LuCI to chacne the subnet but got an error, and had to revert, tried using a command line, it locked me out and had to reflash drive.

Frimware Version:
OpenWrt SNAPSHOT r26812-75081235b8 / LuCI Master 24.158.03388~a6f8361

My Interfaces

My console log

root@OpenWrt:~# ubus call system board; \
> > uci export network; uci export wireless; \
> > uci export dhcp
{
        "kernel": "6.6.35",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 1",
        "model": "Raspberry Pi 5 Model B Rev 1.0",
        "board_name": "raspberrypi,5-model-b",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r26812-75081235b8",
                "target": "bcm27xx/bcm2712",
                "description": "OpenWrt SNAPSHOT r26812-75081235b8"
        }
}
package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/axi/1001100000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option band '5g'
        option channel '36'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

The problem here is that the wan subnet is also 192.168.1.0, which overlaps the lan, preventing routing to the Internet. You need to change the Pi's lan to something else such as 192.168.2.1, or if possible change the upstream router to something else.

2 Likes