No internet - D-Link DIR-2660 with VLAN


I am having a problem with D-Link DIR-2660, because I am getting no internet. I tried different settings in Luci and in /etc/config/network. I would be very thankful, if somebody could share the experience to help. Thank you

It is a FTTH internet, where the fibre goes into a ONT box and from there the ethernet cable goes into the WAN port of the router. The ISP has the condition to setup VLAN 31 tagged and DHCP. (Just for Info: It is the provider "Fonira" from Austria, but there is not yet a config on, which I would like to add there, if that is possible.)

I called the ISP "Fonira", they are very friendly and also like to help, but they said they can not see the MAC-address of the OpenWRT-router, so the VLAN seems not to be ok. They only see the MAC address of their Zyxel-router that came on standard.

PS.: According to the backside of the router it is version A2. According to LuCI it is A1.

I can share all the parameters I have below or if anything additional is needed of course also.

Thank you very much for any help

Best regards

Model accoding to LuCI: D-Link DIR-2660 A1
Architecture: MediaTek MT7621 ver:1 eco:3
Firmware Version: OpenWrt 21.02.0 r16279-5cc0535800 / LuCI openwrt-21.02 branch git-21.231.26241.422c175
Kernel Version: 5.4.143


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd44:c5d0:de85::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth0.31'

Most likely it should be option device 'wan.31'

You are my hero :muscle: Thank you

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.