No internet connection sometimes in relation to VPN

Hi,

I've some issues with my internet connection when I'm using the NordVPN client on my Linux client computer to connec to VPN. It worked fine for many months, but now I can't seem to get a connection to the internet when I'm connected to VPN using the NordVPN app on my client machine AND I'm connected to NordVPN via the client on the openwrt router.

on Openwrt have two ways configured to connect to NordVPN, Wireguard and NordVPN.
Wireguard works fine, but OpenVPN does not. Is there somethin obviously wrong in my config which I paste below?

I have issues logging in to ChatGpt. It seems to have something to do with my VPN connection. This is why I'm depending on the NordVPN linux app to be able to change servers all the time. Also, I want all traffic to go through some VPN server. This is why I'm using the VPN client on OpenWRT.

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'jkljlkjl'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.201.1'

config interface 'wan'
	option device 'eth1'
	option proto 'static'
	option ipaddr '192.168.100.35'
	option netmask '255.255.255.0'
	option gateway '192.168.100.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config interface 'novpn'
	option proto 'none'
	option device 'tun0'

config interface 'wireg'
	option proto 'wireguard'
	option private_key 'some key'
	list addresses '10.5.0.2'
	option mtu '1420'

config wireguard_wireg
	option description 'cz103.nordvpn.com'
	option public_key 'cyxcxycy='
	list allowed_ips '0.0.0.0/0'
	option endpoint_host 'cz103.nordvpn.com'
	option endpoint_port '51820'
	option persistent_keepalive '25'
	option route_allowed_ips '1'

Two possible problems I can think off:
One is you are running a tunnel in a tunnel which is a bad idea altogether but if you cannot avoid it you should lower the mtu of the inner tunnel (your pc with the app) use at least 80 bytes less.
Second problem is address collision, both tunnels cannot have the same address if you connect to the same VPN server.