No internet connection. set up network. help!

all right:)

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd57:6c98:bf45::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.2.1'
        option dns '192.168.1.1'
        option ipaddr '192.168.1.12'

config interface 'wan'
        option device 'dsl0'
        option proto 'dhcp'
        option username 'username'
        option password 'password'
        option ipv6 '1'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

Again the mismatch between 192.168.1.x and 192.168.2.x stuff.

beat me to it !
:stuck_out_tongue:

you didn't read No internet connection. set up network. help! - #31 by frollic

sorry, I do not understand all this :frowning:

is that right?

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'
        option ipaddr '192.168.1.12'

Sure looks better, but you wrote your easybox had 192.168.2 so you need to put everything in the 192.168.2 subnet.

ok, i changed it, but it does not work

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.2.1'
        option dns '192.168.2.1'
        option ipaddr '192.168.2.12'

config interface 'wan'
        option device 'dsl0'
        option proto 'dhcp'
        option username 'username'
        option password 'password'
        option ipv6 '1'

Did you do a network restart too?

I restarted the network

perhaps i have connected the laptop to the fritzbox incorrectly?
I have connected lan to lan, right?

and can you ping 192.168.2.1 from the fritz, which I assume have the IP 192.168.2.12 ?

this does not work

ok ...

is there an error ?

and how are they connected ?

root@OpenWrt:~# ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1): 56 data bytes

nothing happens after that

i have the laptop connected to the fritzbox via lan-lan and the laptop is connected to the easybox via wlan

well, you need to connect the fritz to the easybox, don't you ?
or else, there's no internet access.

1 Like

Windows in its standard configuration as a user endpoint expects to be connected to a network via either Ethernet or WiFi, but not both at the same time. If you try to do that, one of the connections will usually be ignored. It does not link them together.

You need to disconnect the new router from the laptop and connect it to the existing router's LAN directly. This is what "LAN to LAN connect" means-- connect a LAN port of the new router to a LAN port of the existing main router. Then connect the laptop to the same network either by wifi or wired.

thank you for your help and time. it has now worked. i have connected the easybox with the fritzbox

thank you very much :slight_smile:

great!

For future fun, you could play around with the TTL settings for the thether, since it seems you can get totally unlimited data on mobile subscriptions, if set correctly :wink:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

i have another problem. after installing luci and the associated drivers for usb tethering, i can't log into my fritzbox's wifi with openwrt. i'm at a loss, what could it be?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.