No internet connection on x86 router

Hello everyone,

Bear with me here, I'm new to networking and linux but I'm learning as much as I can.

I have a x86 QOTOM mini pc that I have loaded with the OpenWrt 19.07.03 release. I was able to access the GUI by connecting the QOTOM to my laptop on eth0. From there I installed a slew of packages after I connected the QOTOM to my old router, an Edgerouter X, on eth1. The ER-X is connected to my DOCSIS 3.1 Netgear CM1200 modem. My ISP is WOW Internet.

My issue occurs when I try to connect my QOTOM (which I am hoping will become my main router) directly to my modem. I am no longer able to ping google or update the package lists from the GUI. If I am not mistaken, part of the problem is because my client (laptop) is still connected to the eth0 port while my modem is connected to eth1? Shouldn't this be opposite? However, when I attempt to do this, I can no longer access the GUI for my QOTOM router.

I would greatly appreciate any help and insight.

Thanks all!

Have you set up PPPOE on the QOTOM? (although I'm not totally sure about your setup) You'll need to define that in the WAN interface and bridge your other NICs on the LAN if you have more than 2 ports. On my generic x86 it detects my nics in a funny order so you'll have to work out which they are. All of which you can do offline not attached to the modem.

And backup lots. Worth having a look for scripts to dump all your installed packages to file so you can reinstall them quickly too.

No, I did not set up PPPOE on the QOTOM. Before attempting this OpenWRT project my router was setup as DHCP. Before I had a router, when connecting my PC directly to my modem (for testing!) I set it as DHCP as well. Would I not be able to use DHCP settings for the OpenWRT router?

Also, could you elaborate a bit on how to "bridge my other NICs on the LAN"? I have 4 ports on the QOTOM.

For reference, here is the interfaces page. Currently the only connection is from the QOTOM to my PC via eth0 on the QOTOM: https://i.imgur.com/nnKRhGf.png

EDIT: Now have internet connectivity. Restarting modem and OpenWRT router at the same time solved the problem. Based on ifconfig's returns from before and after the restart, it appears the modem was not assigning an IP address via DHCP to the router, which matches a few other posts on this forum.

My new issue is I cannot seem to get my wireless AP (an Eero base provided by my) to be recognized by my router.

I'm presuming you have to login to your ISP. I have what could be similar setup via my fibre modem. PPPOE connects wan to the ISP, but it depends on what sort of modem you have and your ISP. and you'll need to set DHCP on the lan interface.

There must be a ton of guides out. Granted most of seem to use config files. But its really very straight forward in LUCI.

Network>Interface and edit wan and lan in turn. Be careful not to kill the port you're using to connect with though. Got a feeling I made that mistake once.




Get the lan working and that should take care of itself. Best to assign a static IP to the AP both under DHCP and the same in the AP. Make sure its not trying to claim the same IP as your router.

Could you link any of those guides? Searching for what I'm trying to accomplish doesn't seem to come up with anything relevant.

Also, when I spoke with my ISP on the phone they said to use DHCP to set up clients but no combination of interface settings is allowing connectivity.

To add another LAN device such as an AP, add an additional Ethernet port to the lan network bridge and plug it in there. Or you can use an external Ethernet switch to expand the LAN, or a combination of both.

I assume you have the WAN working now on eth1, so use eth2 and/or eth3 for additional LAN.

I know this is an older thread and I hope you got it recolved.

With ISPs, I have often found I needed to power down both the ISP provided modem and the router to get a new router to work. Sometimes I've had to do a few power cycles on the ISP Modem for it to release the DHCP of the old router.