No Internet connection on OpenWrt wireless access point

I installed OpenWRT my TP-Link TL-WR841N, yet I have nothing to do with it other than setting it as access point only mode:

  1. All settings default
  2. Plug a cable from one of its LAN port to my main router's LAN port (or switch)
  3. Disable DHCP server for LAN interface using LuCI web interface
  4. Config the wireless parameters as needed

Today I tried SSH to my access point to install some packages, and a simple update command failed:

root@OpenWrt:~# opkg update
wget: bad address ''
wget: bad address ''
Signature check failed.
Remove wrong Signature file.

It seems my access point has no Internet connection by itself:

root@OpenWrt:~# nslookup
Address 1: localhost

nslookup: can't resolve '': Name or service not known

All clients connected to it can access the Internet normally. What is the cause of this problem and how can I solve it?

Chaos Calmer is no longer maintained, hasn't been for many years, and, as a result, its kernel, the 802.11 protocols, and many of the third-party packages that make up the OpenWrt distro are known to be very insecure.

Upgrading to 18.06 or later is really required, both for your benefit, as well as the security of others on the Internet.

I don't know which of the very different version you have, so looking at would be helpful.

The problem you are seeing is likely that you don't have name services or default route for this OpenWrt box. You need to add the nameserver and default route that your other router is giving out.


I installed version 15 a long time ago and will update to latest version when I have spare time. I am not really familiar with OpenWrt's network manager and/or DNS resolver and how to config it. Can you a little bit more specific? Note that I do not have any cable plugged into my 841N's WAN port -- it may be the reason why it couldn't get configuration from the DHCP server (my main router) and I had to set its IP address manually.

I would pick a "good" IP address for your OpenWrt router so that you can easily access it, rather than trusting what your "main" router hands out. That way too, if the main router is having problems, you can still connect to your OpenWrt box. I would assign the IP address, route, and DNS as static. Do you have LuCI running on your device?


The device itself in any mode still requires valid and complete ip setting (address mask gateway dns).
In router mode most of the times it is obtained by DHCP client on WAN side from ISP but in your case I believe you need to set it up manually.

I would rather create a subnet for wireless, use the AP as a router (without NAT), and add a static route on your main internet device (aka Wifi Subnet via OpenWRT AP)

Edit: Jeff already mentioned it :slight_smile:

1 Like

I already set my access point's IP and net mask manually, but forgot to give it a DNS server. The tutorial I read several years ago did not tell me to do that probably because it is not needed for an access point. Now that I set the DNS server to my main router (I think it has a DNS cache service) and everything works.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.